Bugzilla does not put a code page tag in HTML pages

RESOLVED DUPLICATE of bug 126266

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 126266
16 years ago
6 years ago

People

(Reporter: pashkov, Assigned: justdave)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: 

We use bugzilla to track bugs with description in russian language.
Bugzilla send an e-mail notifications in koi8-r charset (correct tag is put in 
a message body). But it does not put a correct code page tag into HTML page.

So a user enters a bug in DEFAULT browser code page (windows-1251). After that 
here comes an e-mail message that is NOT translated from win1251 to koi8-r. 
It's possible to read bug number only :-). Then HTML page is displayed 
correctly (since browsers default code page is win1251 again).

Possible solutions:
1) Bugzilla should allow setting default code page for HTML pages it shows.
2) Bugzilla should allow automated code page translations. (i.e. if I prefer to 
use win1251 on a web-site and koi8-r in e-mail, I should not have problems:)

Reproducible: Always

Steps to Reproduce:
1. Enter new bug report in russian language (in fact win1251 code page)
2. Open this bug report on a web-page and in e-mail program
Actual Results:  
Web-page is displayed correcly (however HTML page DOES NOT contains code page 
tag)

E-mail message is displayed in different code page (koi8-r) - possibly 
depending on mail-server settings. It's impossible to read mail-message.

Expected Results:  
Show web-page in win1251
Send message in koi8-r

Everything should be corectly displayed.

*** This bug has been marked as a duplicate of 126266 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.