Delay between opening message in preview pane and marking it as read

RESOLVED DUPLICATE of bug 75866

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 75866
15 years ago
14 years ago

People

(Reporter: Vadim Kutsyy, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

There should be an option of marking message as read.  When message is selcted
in preview plane it is marked as read right away.  Instead there should be an
option that message is marked as read after x seconds of viewing (x=0 is current
behavior).

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Steps to reproduce:
1. Open mail and turn on the preview pane.
2. Select a message.
3. Quickly select another message.

Actual result:
First message is marked as read.

Expected result:
First message is not immediately marked as read; UI presumes that the first
message was selected by accident.  For example, Microsoft Outlook Express
implements the expected behavior.

I'll expand the summary to cover what you want, to catch people searching
on |preview|.
Summary: Read delay → Delay between opening message in preview pane and marking it as read
(Reporter)

Comment 2

15 years ago
Thank you for writing better description

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 75866 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.