title attribute can't handle newline characters

RESOLVED DUPLICATE of bug 67127

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 67127
15 years ago
13 years ago

People

(Reporter: jason pepas, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030327 Debian/1.3-4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030327 Debian/1.3-4

if there is a newline character "\n" in a title attribute, mozilla renders an
unknown glyph instead of making a multi-line tooltip.

Reproducible: Always

Steps to Reproduce:
1.go to http://www.w3.org/TR/html4/types.html#type-text
2.hover your mouse over the %Text link in section 6.3 Text Strings


Actual Results:  
mozilla renders a glyph for each occurence of a newline character in a title
attribute.

Expected Results:  
mozilla should have created a multi-line tooltip instead.
(Reporter)

Comment 1

15 years ago
Created attachment 120630 [details]
screenshot of mozilla misbehaving
(Reporter)

Comment 2

15 years ago
Created attachment 120631 [details]
konqueror handles this situation correctly
*** This bug has been marked as a duplicate of 67127 ***

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
Created attachment 120637 [details]
internet explorer handles this correctly
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.