winamp.com - mozilla downloads text instead of files when following any skin download link

RESOLVED FIXED in Future

Status

RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: tarundi, Unassigned)

Tracking

unspecified
Future
x86
All

Details

(Whiteboard: [mime type] [not responsive], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030415
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030415

when trying to download any skin from http://classic.winamp.com/skins/ by
following the desired link mozilla starts downloading a text chain instead of
asking what to do with the file type. for example
http://ftpwa.newaol.com/customize/component/2003/3/30/S/JadeTube_3.wsz will make
mozilla show the text i'm talking about but by changing the protocol to look
like this ftp://ftpwa.newaol.com/customize/component/2003/3/30/S/JadeTube_3.wsz
it works just fine. i guess it may be a issue with the file type assosiaton?

Reproducible: Always

Steps to Reproduce:
1. note: winamp must be installed
2. open http://classic.winamp.com/skins/ and select the skin of your taste 
3. click download on any skin link
Actual Results:  
mozilla starts showing a text chain that is the file it should be prompting for
download

Expected Results:  
ask what to do with the file instead of start displaying a non sense text

http://ftpwa.newaol.com/customize/component/2003/4/14/S/Voyager_1a.wsz
this first addres does not work
ftp://ftpwa.newaol.com/customize/component/2003/4/14/S/Voyager_1a.wsz
this is properly working

Comment 1

16 years ago
MIME type is text/plain, which is wrong.
Should be something else like application/binary or perhaps a Winamp-specific
MIME type.
FTP doesn't use MIME types, hence it works in FTP mode.
Assignee: law → susiew
Status: UNCONFIRMED → NEW
Component: File Handling → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Summary: mozilla downloads text instead of files when following any skin download link → winamp.com - mozilla downloads text instead of files when following any skin download link
Whiteboard: [mime type]
Version: Trunk → unspecified

Comment 2

16 years ago
MIME type could be set to the unofficial interface/x-winamp-skin according to
the forums:
http://forums.winamp.com/showthread.php?s=&threadid=99555
(there's also a workaround on the client side for this issue)
(Reporter)

Comment 3

16 years ago
well, i've tried the proposed solution in that forum and did not work for me.
that  is because settings were good and mozilla has its own MIME types. (hate to
say this but...) it worked fine on msie in both cases. i'll be waiting

Comment 4

16 years ago
Winamp is looking at the issue. Marking assigned.
Status: NEW → ASSIGNED

Comment 5

16 years ago
*** Bug 202938 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
default
Assignee: susiew → english-us
Status: ASSIGNED → NEW
QA Contact: zach → english-us

Comment 7

16 years ago
*** Bug 215484 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 215481 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
contacted
Status: NEW → ASSIGNED
OS: Windows XP → All
Target Milestone: --- → Sep

Comment 10

16 years ago
*** Bug 199469 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 221749 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
contacted again. 
Target Milestone: Sep → Nov

Comment 13

15 years ago
Looks like winamp is going the way of netscape now that AOL has buddied up with
Real again. This was received after using their feedback form.

The original message was received at Fri, 10 Oct 2003 10:51:56 -0700 (PDT)
from genghis.streamops.aol.com [64.236.62.131]

   ----- The following addresses had permanent fatal errors -----
<winampsupport@spinner.com>
    (reason: 553 5.3.0 <winampsupport@spinner.com>... No such user in
spinner.com.Please check the address.)

   ----- Transcript of session follows -----
... while talking to shemail.aoltw.net.:

>>>>>> RCPT To:<winampsupport@spinner.com>

<<< 553 5.3.0 <winampsupport@spinner.com>... No such user in spinner.com.Please
check the address.
550 5.1.1 <winampsupport@spinner.com>... User unknown



Reporting-MTA: dns; ywing.netscape.com
Received-From-MTA: DNS; genghis.streamops.aol.com
Arrival-Date: Fri, 10 Oct 2003 10:51:56 -0700 (PDT)

Final-Recipient: RFC822; winampsupport@spinner.com
Action: failed
Status: 5.3.0
Remote-MTA: DNS; shemail.aoltw.net
Diagnostic-Code: SMTP; 553 5.3.0 <winampsupport@spinner.com>... No such user in
spinner.com.Please check the address.
Last-Attempt-Date: Fri, 10 Oct 2003 10:52:16 -0700 (PDT)



Received: from mail.winamp.com (genghis.streamops.aol.com [64.236.62.131])
	by ywing.netscape.com (8.12.8/8.12.8) with ESMTP id h9AHptO5027432
	for <winampsupport@spinner.com>; Fri, 10 Oct 2003 10:51:56 -0700 (PDT)
Received: by mail.winamp.com (Postfix)
	id 20872EFA570; Fri, 10 Oct 2003 10:51:20 -0700 (PDT)
Delivered-To: wasupport@winamp.com
Received: from localhost (localhost [127.0.0.1])
	by mail.winamp.com (Postfix) with ESMTP id E3CB2EFA56F
	for <wasupport@winamp.com>; Fri, 10 Oct 2003 10:51:19 -0700 (PDT)
Received: from mail.winamp.com ([127.0.0.1])
 by localhost (www.firehose.net [127.0.0.1:10024]) (amavisd-new) with ESMTP
 id 49467-09 for <wasupport@winamp.com>; Fri, 10 Oct 2003 10:51:13 -0700 (PDT)
Received: from mail2.spinner.com (mail2.spinner.com [205.188.246.17])
	by mail.winamp.com (Postfix) with ESMTP id AEBFEEFA542
	for <support@winamp.com>; Fri, 10 Oct 2003 10:51:12 -0700 (PDT)
Received: from localhost (wampweb1-qfe0.spinner.com [205.188.245.20])
	by mail2.spinner.com (Postfix) with SMTP id 486C788B30
	for <support@winamp.com>; Fri, 10 Oct 2003 13:50:05 -0400 (EDT)
Message-ID: <28426008.1065808272143.JavaMail.dynamo@localhost>
Date: Fri, 10 Oct 2003 13:51:12 -0400 (EDT)
From: bc@bclary.com
To: support@winamp.com
Subject: Web Site Bug Report
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Virus-Scanned: by amavisd-new

-> Future. If you want to complain to them, please do so. 
Whiteboard: [mime type] → [mime type] [not responsive]
Target Milestone: Nov → Future

Comment 14

15 years ago
WFM: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
I am prompted to download the skin files.

Comment 15

15 years ago
the .wal links are not served in text/plain but .wsz still are, see an example
with http://classic.winamp.com/skins/details.php?id=52206 (click "download")

Comment 17

15 years ago
You're correct, neither of those WFM, contacting.

Comment 18

15 years ago
I am now getting a download prompt with: the links provided in comment #15 and
comment #16
Note: I am using Firebird 0.7 - official release - therefore well before the
implemented fix to help with MIME type problems. 

I would recommend resolving this as fixed :)

Comment 19

15 years ago
Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 20

15 years ago
- Go to Edit menu --> Preferences --> Navigator --> Helper Applications
- Click on New type
- Name it like you want (I named it application/winamp5skin)
- Extension: WSZ
- Click on Open it using the default application (in that case, WinAMP is set by
the OS to open WSZ files)
- OK 
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.