Closed Bug 202291 Opened 17 years ago Closed 17 years ago

XML Parsing Error: undefined entity. Page does not display

Categories

(Core :: XML, defect)

x86
Windows NT
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 22942

People

(Reporter: kupci2, Assigned: hjtoi-bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

This may be a "Tech Evangelism" type bug (see #84618), however this is the
w3.org site so you'd think the page would be XML compliant.  Workaround is that
this works in IE6. Sim

Reproducible: Always

Steps to Reproduce:
1.open page in mozilla
2.
3.

Actual Results:  
xml parsing error displays

Expected Results:  
display page
Here's the actual error:

XML Parsing Error: undefined entity
Location:
http://www.w3.org/TR/2001/REC-xmlschema-2-20010502/datatypes#built-in-primitive-datatypes
Line Number 2562, Column 53:Currently, there are no <termref             
def="dt-built-in"/>&nbsp;<termref def="dt-
-------------------^
With Camino on OSX Build 2003082102, it is puking on the &eacute; entity as well...

XML Parsing Error: undefined entity
Location: http://studioz.tv/events/calendar.rss
Line Number 219, Column 137:Yoga @ 9pm by Yoga Kitte – Visuals by Nynke—Sound by
Phoenix Family &amp; Rob Rayle—Full Bar plus Smoothies &amp;
Chai—Workshops—Crazy d&eacute;cor by Nik Pastor, Blondie, &amp; various other
artists—Booth by SFWAR—and more!!!
----------------------------------------------------------------------------------------------------------------------------------------^
Confirming on Windows 98, Mozilla 1.5 branch, build 2003091604. Severity normal,
as the page cannot be accessed.

I'm seeing tons of these "XML Parsing error" messages with this build.
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.6a?
Flags: blocking1.5?
Flags: blocking1.4.2?
confirming on Windows 2000, Mozilla 1.5b trunk, build 2003091704.
Also, cannot view "about:".
error message is the following


XML Parsing Error: undefined entity
Location: jar:resource:///chrome/en-US.jar!/locale/en-US/global/about.xhtml

Line Number 95, Column 15:<li>Copyright &copy; 1998-2003 by <a
href="about:credits">Contributors</a> to --------------^
Heikki, do you have time to look into this?
This is probably a dupe of bug 22942. The nsbp entity is defined in the external
DTD (http://www.w3.org/TR/2001/REC-xmlschema-2-20010502/xmlspec-19990429.dtd).
Yup, it's a dupe.

*** This bug has been marked as a duplicate of 22942 ***

*** This bug has been marked as a duplicate of 22942 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
The about: problem was a recent regression (bug 219355) which should be fixed now.
Removing nominations as this is a duplicate.
Flags: blocking1.6a?
Flags: blocking1.5?
Flags: blocking1.4.2?
You need to log in before you can comment on or make changes to this bug.