Devanagari hindi / marathi text selection is currently being done character wise and not glyphwise.

RESOLVED DUPLICATE of bug 283416

Status

()

--
minor
RESOLVED DUPLICATE of bug 283416
16 years ago
11 years ago

People

(Reporter: alkuma, Assigned: prabhat.hegde)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

After a syllable has been created using an Indic Unicode
sequence, it should be the unit of display and cursor movement.
Additionally, when you select the text with a mouse, the raw Unicode letters
are displayed as you select the text creating movement in the text, whereas
the display should remain static as you select it. IE/Windows does both
these things correctly. So does yudit on Linux.

Reproducible: Always

Steps to Reproduce:
1. Make sure you are able to see devanagari,
http://geocities.com/alkuma/seehindi.html 
2. go to http://geocities.com/hanu_man_ji/hindi_page.html
3. Try select some text

Actual Results:  
The text "breaks", ie if I have a conjunct and I drag the mouse over it, I can
actually see the individual characters that make up the glyphs, and depending on
the extent to which I drag, I may select either part of the glyph or the full glyph.

Expected Results:  
While this is really fine, and could also be considered as a feature, it would
be a little disconcerting to users to see the letters "break up" when the select
text. IE does not display this behaviour, the selection happens glyph by glyph
and not character (as in unicode character) by character.

Comment 1

16 years ago
> a syllable has been created using an Indic Unicode
> sequence, it should be the unit of display and cursor movement.

  I have no doubt this is the case most of time. [1]

I'm wondering, however, if it's always the case. Suppose while entering a
syllable made of 4 or 5 Unicode characters (say, KA, Virama, SSA, vowel sign
'x') you realize that 'KA' at the beginning has to be a consonant other than KA.
Wouldn't it be more convenient to be able to move the cursor Unicode char. by
char to replace 'KA' with the correct one than having to remove the syllable as
a whole and to begin from the scratch. Because most Korean input methods have an
option to let users  delete/move cursor 'vowel/consonant'-wise instead of
syllable-wise, I have been wondering what users of Indic scripts expect in this
regard.

[1] Unicode technical committee gave up definining 'graphemes' for Indic scripts
while it provides the definition of graphemes for Korean script.(See UTR #29 : 
 http://www.unicode.org/reports/tr29/)  The reason cited was it's not their job
to define what constitutes a 'unit' in Indic scripts and that had better be left
to graphalogists(sp?) and Indian people. 

BTW, what build did you  try under Linux? Was it Mozilla-X11core (as opposed to
Xft) with CTL enabled? At the moment, only Mozilla-X11core supports Devanagari
on Linux.(see bug 204286 for Xft.) 
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This is a valid bug, though it may be a dupe
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 283416 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Component: Layout: CTL → Layout: Text
QA Contact: arthit → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.