Closed Bug 202386 Opened 18 years ago Closed 15 years ago

If a table horizontally overflows, page doesn't start from Right to Left when dir is set to RTL

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: david_vozza, Assigned: mkaply)

References

Details

(Keywords: rtl, Whiteboard: [reflow-refactor])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When dir is set to RTL and a table horizontally overflows, Mozilla doesn't load
the page from Right to Left as it should.
It loads it from left to right, so user has to scroll to see content on right side.

Reproducible: Always

Steps to Reproduce:
1.Create a page with a table that horizontally overflows and dir set to RTL.
2.Load the page.


Actual Results:  
You see that page starts horizontally form left to right.

Expected Results:  
You should view the page starting from right to left.
Attached file test case
Depends on: 6976
CONFIRMED with Mozilla/5.0 (Windows; U; Windows NT 5.2; he-IL; rv:1.5)
Gecko/20031007
Status: UNCONFIRMED → NEW
Ever confirmed: true
Seeing this on OS X => All/All
OS: Windows 2000 → All
Hardware: PC → All
Depends on: 318116
Attached file simpler testcase
Similar testcase, with just a single cell, with long, unbreakable, content.
Please note that dbaron's proposed patch for bug 192767 causes the horizontal scrollbar to disappear from the testcases affected by this bug, so it would be desirable to fix this bug for the same release as the one bug 192767 is fixed for.
Specifying a (correct) width for the table fixes the problem, indicating that this is an "intristic width" issue. So, I'm putting [reflow-refactor] on the status whiteboard, in hope that bug 300030 will fix this. 
No longer depends on: 318116
Summary: If a table horizontally overflows, page doesn't start from Right to Left when dir is set to RTL. → If a table horizontally overflows, page doesn't start from Right to Left when dir is set to RTL
Whiteboard: [reflow-refactor]
This looks like it will be fixed by the patch on bug 96394.
Depends on: 96394
Fixed on trunk by checkin of bug 96394.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.