strict-js warnings at Firebird startup

VERIFIED FIXED in Firebird0.7

Status

()

--
minor
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: holyspirit, Assigned: bugs)

Tracking

unspecified
Firebird0.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030420 Phoenix/0.5+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030420 Phoenix/0.5+

1) redeclaration of currentIndex (interesting code dup, copy and paste error?)
2) redeclaration of uniqueId
3) makes insertItem returns null on failure (previously return;)


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Created attachment 121192 [details] [diff] [review]
fix
What warning are you talking about?
(Reporter)

Comment 3

16 years ago
you may need to turn on show strict warnings to get those warning messages...

Updated

16 years ago
Summary: remove warning at Firebird startup → strict-js warnings at Firebird startup

Comment 4

16 years ago
confirming.
-> NEW
-> minor

Steps to Reproduce:
1. Add the following code to your user.js file:
user_pref("javascript.options.strict", true);
user_pref("javascript.options.showInConsole", true);
2. Restart Firebird Browser and Open JavaScript Console.

Actual Results:  
*******************************************************
Warning: redeclaration of var uniqueId
Source File: chrome://global/content/widgets/toolbar.xml#toolbar.insertItem()
Line: 13, Column: 18
Source Code:
              var uniqueId = (new Date()).getTime()+this.childNodes.length;

Warning: redeclaration of var uniqueId
Source File: chrome://global/content/widgets/toolbar.xml#toolbar.insertItem()
Line: 19, Column: 18
Source Code:
              var uniqueId = (new Date()).getTime()+this.childNodes.length;

Warning: function insertItem does not always return a value
Source File: chrome://global/content/widgets/toolbar.xml#toolbar.insertItem()
Line: 53, Column: 26
Source Code:
            return newItem;

Warning: redeclaration of var currentIndex
Source File: chrome://global/content/widgets/tabbrowser.xml#tabbrowser.removeTab()
Line: 47, Column: 16
Source Code:
            var currentIndex = this.mPanelContainer.selectedIndex;

Expected Results:  
No Warnings.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
Comment on attachment 121192 [details] [diff] [review]
fix

chanial, you are the only one I know which is currently working on Firebird :)
Attachment #121192 - Flags: review?(chanial)
*** Bug 213226 has been marked as a duplicate of this bug. ***
Reassigning to Ben as per comment 2 in bug 213226.
Assignee: blakeross → bugs
Component: General → Toolbars
QA Contact: asa → bugzilla

Comment 8

16 years ago
This patch looks fine to me, its the same thing I did in the patch on bug 213226

Comment 9

16 years ago
Comment on attachment 121192 [details] [diff] [review]
fix

looking good.
Attachment #121192 - Flags: review?(chanial) → review+

Comment 10

16 years ago
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firebird0.7
verified with 20030723 trunk build on W2K.
Status: RESOLVED → VERIFIED
Taking QA Contact
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.