Closed Bug 202959 Opened 19 years ago Closed 15 years ago

implement p3p in Firefox

Categories

(Firefox :: General, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: wlevine, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030422 Firebird™ Browser/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030422 Firebird™ Browser/0.6

there is no p3p in firebird but there is in mozilla

Reproducible: Always

Steps to Reproduce:
1. open options box
2.
3.

Actual Results:  
only limited cookie control

Expected Results:  
should have p3p stuff
Depends on Bug 62399 ?
Confirming RFE
Status: UNCONFIRMED → NEW
Ever confirmed: true
maybe as an extension available via the installer?  this doesn't belong in the
core UI
QA Contact: asa → mpconnor
I'm going to try to implement this into an extension, the current plan for
cookies will use some p3p influence, but will not have the ubergeek config
options.  The extension will override that UI and replace with something more
useful.
Assignee: blake → mconnor
Summary: implement p3p in firebird → implement p3p in Firefox
so I changed my mind.  Also since p3p isn't built by default anymore, the
extension idea is a lot more complicated.
Assignee: mconnor → nobody
At this point I suggest to wait for the 1.1 specification to be released...
at this point, p3p might be getting removed from default seamonkey builds as
well, and by might, I mean probably will.  Its unmaintained, and of dubious
benefit to users.  If there is a 1.1 spec coming out, I seriously doubt Mozilla
will ever be compliant based on the complete lack of ownership or desire to make
this work.
(In reply to comment #6)   
> At this point I suggest to wait for the 1.1 specification to be released...   
 
Note that you don't have to wait for the 1.1 Specification as it will be 100% 
backwards compatible. So it is possible to implement P3P 1.0 and augment it 
later with the features of 1.1.  
 
(In reply to comment #7) 
> at this point, p3p might be getting removed from default seamonkey builds as 
> well, and by might, I mean probably will.  Its unmaintained, and of dubious 
> benefit to users.  If there is a 1.1 spec coming out, I seriously doubt 
Mozilla 
> will ever be compliant based on the complete lack of ownership or desire to 
make 
> this work. 
 
1/ I would be interested why some people in Mozilla still talk about P3P 
having dubious benefit to users while the rest of the world acknowledges the 
benefit of P3P (including a large number of european data commissioners) 
 
2/ The current implementation is just a reaction on IE6 and a quickhack from 
folks from IBM made at that time. The music is in the full P3P implementation, 
not only in the compact format. Privacy Bird showed that it can be 
implemented. Before removing anything, we might want to look for a new 
maintainer. 
rigo: are you volunteering?
any spec that bases privacy protection on the honour system screams dubious 
benefits to me, but that's not really the point here.

If someone wants to step up and maintain the code, feel free.  As it stands, no 
one wants to, no one has.  At this point there's a good chance it'll just 
bitrot and get cvs removed.  If you post to the primary newsgroup for a project 
and no one utters a peep other than "seems like a good idea" including w3 
members, its a good sign there won't be a maintainer anytime soon.
(In reply to comment #10) 
> rigo: are you volunteering? 
 
I'm looking into finding people (and perhaps funding). I see that in the 
actual community there is not enough interest. This is important for me to 
know so I can look into getting new people (and a maintainer) 
 
 
(In reply to comment #11) 
> any spec that bases privacy protection on the honour system screams dubious  
> benefits to me, but that's not really the point here. 
 
P3P is not the honour system you might imagine. If you lie in your privacy 
policy, at least most western countries provide some legal sanctions. As I'm 
from a EU-context, we have even more impressive instruments to correct those 
making incorrect statements. If there is no policy, you can't even compare 
intention and reality. 22 pages of legalese in a privacy policy have proven to 
be less beneficial to a consumer than P3P ;) 
 
For the rest, it is clear that there is no maintainer and nobody inside the 
existing community that is interested. So I will go out trying to find 
someone. Implementing privacy in an user interface might change the browsing 
experience considerably. Make them feel to be in control is the goal.  
 
You might also be interested in the PrivacyFox-extension:
http://privacyfox.mozdev.org/

The project (in which I am not involved, but I just stumbled upon it) aims to
create a Firefox-extension like AT&T's Privacy Bird. The project already has a
document at http://privacyfox.mozdev.org/PaperFinal.pdf and a working extension.
I do not know the status of the code and how complete it is (I guess it is in
early stages of development; the project seems to be started in December 2004).
Just wanted to see if anyone was working on this. 

Either way, a good source of info can be found in AT&T's source code for Privacy Bird which can found found here:

http://www.privacybird.com/dist/privacybird-source.tar.gz

as mentioned in their FAQ: http://www.privacybird.com/#support

One note: the file is roughly 25 MB.
QA Contact: mconnor → general
p3p has been permanently cvs removed, marking wontfix.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.