M17 FF092 Flash related crashes [@ NPSWF32.dll]

RESOLVED DUPLICATE of bug 200511

Status

defect
--
critical
RESOLVED DUPLICATE of bug 200511
16 years ago
3 years ago

People

(Reporter: jcarpenter0524, Assigned: peterlubczynski-bugs)

Tracking

({crash, relnote, topcrash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

16 years ago
(24)  	 26  	 NPSWF32.dll
 
   Total Runtime:         628 (min) - 960212 (max)
   Crash date range:      2003-04-12 to 2003-04-21
   Crash build range:     2003040105 to 2003040105
   Unique Users:          23


   Stack Trace: 
   NPSWF32.dll + 0x1cf5e (0x0902cf5e)
   NPSWF32.dll + 0x21b0b (0x09031b0b)
   NPSWF32.dll + 0x1e7e6 (0x0902e7e6)
   NPSWF32.dll + 0x1ece9 (0x0902ece9)
   NPSWF32.dll + 0x1f00e (0x0902f00e)
   NPSWF32.dll + 0x23882 (0x09033882)
   NPSWF32.dll + 0x2395e (0x0903395e)
   NPSWF32.dll + 0x41ec3 (0x09051ec3)
   NPSWF32.dll + 0x41a08 (0x09051a08)
   NPSWF32.dll + 0x41dd2 (0x09051dd2)
   NPSWF32.dll + 0x3ceb0 (0x0904ceb0)
   NPSWF32.dll + 0x4d364 (0x0905d364)
   NPSWF32.dll + 0x4b1bb (0x0905b1bb)
   USER32.dll + 0x2a244 (0x77e3a244)
   USER32.dll + 0x6b21 (0x77e16b21)
   USER32.dll + 0x6b44 (0x77e16b44)
   PluginWindowEvent_Handle
[c:/builds/seamonkey/mozilla/modules/plugin/base/src/nsPluginNativeWindowWin.cpp
 line 326]
   PL_HandleEvent	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c  line 660]
   PL_ProcessPendingEvents	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c
 line 596]
   _md_EventReceiverProc	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c 
line 1396]
   nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480]
   main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1287]
   main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1645]
   WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1666]
   WinMainCRTStartup()
   KERNEL32.dll + 0x2847c (0x77ea847c)


   (19372171)      URL: http://www.planettribes.com/allyourbase/video.shtml
   (19372171) Comments: I was viewing the two videos from the planettribes.com
all your base are belong to us site.  Afer video 2 started  this error occurred.
 The error did not happen when the site was revisited.  
   (19298069)      URL: www.atomicmpc.com.au
   (19298069) Comments: tabbed  playing film from theinfortmationminister.com  
 It's funny...  
   (19282903)      URL: www.whenharrymetlloyd.com
   (19282903) Comments: flash encountered a fatal error  ignored error which
repeated three times  then browser crashed.
   (19162896) Comments: I was reading messages in a newsgroup  the crash
occurred when i moved from the message that i was reading to the next.
   (19101119)      URL: www.rackable.com
   (19101119) Comments: launching a Flash presentation?

Updated

16 years ago
Severity: normal → critical

Comment 1

15 years ago
Unable to reproduce this with the latest version of Mozilla & Flash Player 
(Mozilla 1.6 and Player 7). Confirmed on Win 2k/ XP/ Mac OX X.

Comment 2

15 years ago
WFM.

All sites listed works fine here...

Shockwave Flash 7.0 r19
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040330
Microsoft Windows 2000 Pro 5.00.2195 SP4

Comment 3

15 years ago
We have been seeing Flash related crashes with almost every major Mozilla
release.  The stacks from Talkback have not been useful and a lot of the user
comments don't provide enought data to help us reproduce the crash.  Still, it's
probably worth keeping this bug open for future reference.

This continues to be a topcrash for Mozilla 1.7 rc1.  Here is a recent incident
from that release:
Incident ID: 31408
Stack Signature	NPSWF32.dll + 0x34860 (0x03664860) 041e4e8f
Email Address	
Product ID	Mozilla17
Build ID	2004042109
Trigger Time	2004-04-26 23:12:10.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	NPSWF32.dll + (00034860)
URL visited	yahoo scox message boards
User Comments	A flash animation ad was playing (something with a NASCAR car)
Since Last Crash	sec
Total Uptime	sec
Trigger Reason	Access violation
Source File Name	
Trigger Line No.	
Stack Trace 	
NPSWF32.dll + 0x34860 (0x03664860)
NPSWF32.dll + 0x3659f (0x0366659f)
NPSWF32.dll + 0x37de1 (0x03667de1)
NPSWF32.dll + 0x37e3e (0x03667e3e)
NPSWF32.dll + 0x37e3e (0x03667e3e)
NPSWF32.dll + 0x37e3e (0x03667e3e)
NPSWF32.dll + 0x2a6f1 (0x0365a6f1)
NPSWF32.dll + 0x2a913 (0x0365a913)
NPSWF32.dll + 0x5266f (0x0368266f)
NPSWF32.dll + 0x5212b (0x0368212b)
NPSWF32.dll + 0x52580 (0x03682580)
NPSWF32.dll + 0x4bee5 (0x0367bee5)
NPSWF32.dll + 0x5f9db (0x0368f9db)
NPSWF32.dll + 0x5d5a2 (0x0368d5a2)
USER32.dll + 0x3a50 (0x77d43a50)
USER32.dll + 0x3b1f (0x77d43b1f)
USER32.dll + 0x3d79 (0x77d43d79)
USER32.dll + 0x3ddf (0x77d43ddf)
nsAppShellService::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 524]
main1
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1313]
main
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1783]
WinMain
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1809]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)
Summary: M140A topcrash [@ NPSWF32.dll] → M17rc1 Flash related crashes [@ NPSWF32.dll]

Comment 4

15 years ago
Here is all the data we currently have for this crash in rc1.

Comment 5

15 years ago
do we have any way of finding out what version of flash these crashes are in or
are we assuming 7.0r19?

Comment 6

15 years ago
I can look at the detailed Talkback incident reports for each crash and find out
the version for the Flash .dll in the plugins folder.  It might take a while,
but it's doable.  But I'm guessing most Mozilla 1.7x users will have the latest
version of Flash...

Comment 7

15 years ago
Updating summary:  M17rc1 -> M17rc2
Summary: M17rc1 Flash related crashes [@ NPSWF32.dll] → M17rc2 Flash related crashes [@ NPSWF32.dll]
Jay, are these still coming in?

Comment 9

15 years ago
Yeah, there are still a good number of Flash crashes showing up in Mozilla 1.7
rc2.  If we think it's worthwhile to figure out what versions of Flash people
are using, I can try to hack together a script that will give us the Flash .dll
versions these people have.  It's a little tricky b/c the modules aren't stored
in the Talkback database as strings, so I have to pull out the raw stream of
bytes and figure out what they are.

Comment 10

15 years ago
lets make sure this makes the 1.7 and firefox release notes, and we should also
figure out if we are ready to try some auto responding on stack traces to e-mail
address that are hitting this stack signatures. 

I can also see if it is possible for macromedia to target mozilla browser users
for auto updating of flash on their end.
Keywords: relnote

Updated

15 years ago
Summary: M17rc2 Flash related crashes [@ NPSWF32.dll] → M17 FF092 Flash related crashes [@ NPSWF32.dll]

Comment 11

15 years ago

*** This bug has been marked as a duplicate of 200511 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: bmartin → adobe-flash
Target Milestone: --- → 2003
Version: Trunk → 6.x
Crash Signature: [@ NPSWF32.dll]

Comment 12

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Target Milestone: 2003 → ---
Version: 6.x → unspecified
You need to log in before you can comment on or make changes to this bug.