Firebird brand.properties uses invalid syntax, breaks HTTP specification

VERIFIED DUPLICATE of bug 202918

Status

()

--
major
VERIFIED DUPLICATE of bug 202918
16 years ago
16 years ago

People

(Reporter: bzbarsky, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Where to start.... Ben changed the vendor name for Firebird to "Firebird (tm)"
in the properties file (toolkit/locale/brand.properties).  Unfortunately,
instead of using the proper \uXXXX escape he just stuck some random bytes in
there... also unfortunately, those random bytes get sent out over the networ in
our User-Agent header, which violates RFC 2616 (if you really care, I'll quote
the exact BNF involved).

ccing pch, since lxr and cvs log seem to disagree on what's actually going on
with that file and he may know (as in, he may already have fixed this problem).

Comment 1

16 years ago
Isn't it a dupe of bug 202918?
(Reporter)

Comment 2

16 years ago
Yes, it is.

*** This bug has been marked as a duplicate of 202918 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.