If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

soft hyphenation (­) does not work: words are not divided by ­

VERIFIED DUPLICATE of bug 9101

Status

()

Core
Internationalization
--
trivial
VERIFIED DUPLICATE of bug 9101
15 years ago
15 years ago

People

(Reporter: Sergey Kirienko, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.3) Gecko/20030309
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.3) Gecko/20030309

For example, at http://www.mgubs.ru/projects/variant1/about/appeal.html (sorry,
page in Russian) main text on yellow background has words with $shy;
combinations.  If such word lies at the end of line, there should be no need to
move whole word to the next line, but only a part behind soft hyphen (for ex.
DIVI- and SION at the next line). W3C standards write about it. MSIE browser
does it. Mozilla doesn't.

Reproducible: Always

Steps to Reproduce:
1. Create a text at the webpage with words long enough and combination ­
right in the word.
2. Make the column containing this text narrow enough (you can just resize window)
3. Look how does Mozilla move this words with ­ combination to the next line.

Actual Results:  
Mozilla ignores ­ combination in text.

Expected Results:  
Mozilla should move words partially, by ­, using (-) sign, and no only by
spaces.

Comment 1

15 years ago
not CTL, over to Internationalization.
Component: Complex Text Layout → Internationalization

Comment 2

15 years ago
to Internationalization QA.
Assignee: prabhat.hegde → smontagu
QA Contact: art → ylong

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 9101 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.