Printing this page crashes Mozilla and Phoenix [@ nsLineBox::DeleteLineList]

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
P2
critical
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Barry Treahy, Assigned: roc)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030412
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030412

I have made three attempts in Mozilla (build 2003041208) and one in Phoenix
(build 2003041108) to print this page of the web site and it will crash them
every time.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://www.aceshardware.com/read.jsp?id=55000253
2. Click print
3. What it burp!

Actual Results:  
Complete death.  Mozilla starts up the feedback program, Phoenix goes down in flames

Expected Results:  
Dah, print the page!

Comment 1

15 years ago
Could you provide Talkback incident ID?
Assignee: asa → printing
Component: Browser-General → Printing
Keywords: crash
QA Contact: asa → sujay
When I print this page, I get:

###!!! ASSERTION: This hack should not be needed now!!! See bug 126263.:
'Error', file
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 445
###!!! ASSERTION: translation failed: 'ok', file
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 482

a bunch of times, then a crash as follows at the end of the print:

#0  0x000004ec in ?? ()
#1  0x40e5210a in nsLineBox::DeleteLineList (aPresContext=0x89def00,
aLines=@0x8a30a24)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsLineBox.cpp:306
#2  0x40e07ed2 in nsBlockFrame::Destroy (this=0x8a309e8, aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsBlockFrame.cpp:423
#3  0x40e5210a in nsLineBox::DeleteLineList (aPresContext=0x89def00,
aLines=@0x8a308d4)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsLineBox.cpp:306
#4  0x40e07ed2 in nsBlockFrame::Destroy (this=0x8a30898, aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsBlockFrame.cpp:423
#5  0x40f75ac4 in nsFrameList::DestroyFrames (this=0x8a30824,
aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/base/src/nsFrameList.cpp:130
#6  0x40e1d36b in nsContainerFrame::Destroy (this=0x8a307f0, aPresContext=0x89def00)
    at
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp:140
#7  0x40f75ac4 in nsFrameList::DestroyFrames (this=0x8a30368,
aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/base/src/nsFrameList.cpp:130
#8  0x40e1d36b in nsContainerFrame::Destroy (this=0x8a30334, aPresContext=0x89def00)
    at
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp:140
#9  0x40f75ac4 in nsFrameList::DestroyFrames (this=0x8a302a0,
aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/base/src/nsFrameList.cpp:130
#10 0x40e1d36b in nsContainerFrame::Destroy (this=0x8a3026c, aPresContext=0x89def00)
    at
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp:140
#11 0x40f75ac4 in nsFrameList::DestroyFrames (this=0x8a301d4,
aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/base/src/nsFrameList.cpp:130
#12 0x40e1d36b in nsContainerFrame::Destroy (this=0x8a301a0, aPresContext=0x89def00)
    at
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp:140
#13 0x40f0adde in nsTableFrame::Destroy (this=0x8a301a0, aPresContext=0x89def00)
    at
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/table/src/nsTableFrame.cpp:311
#14 0x40f75ac4 in nsFrameList::DestroyFrames (this=0x8a300b4,
aPresContext=0x89def00)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/base/src/nsFrameList.cpp:130
#15 0x40e1d36b in nsContainerFrame::Destroy (this=0x8a30080, aPresContext=0x89def00)
    at
/home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsContainerFrame.cpp:140

(gdb) frame 1
#1  0x40e5210a in nsLineBox::DeleteLineList (aPresContext=0x89def00,
aLines=@0x8a30a24)
    at /home/bzbarsky/mozilla/xlib/mozilla/layout/html/base/src/nsLineBox.cpp:306
306           child->Destroy(aPresContext);
(gdb) p child
$1 = (nsIFrame *) 0x89e982c
(gdb) p *child
$2 = {<nsISupports> = {_vptr. = 0x41535ae0 <nsHTMLFrameOuterFrame virtual table>}, 
  mRect = {x = 0, y = 180, width = 5040, height = 4200}, mContent = 0x87e0598, 
  mStyleContext = 0x8a30cec, mParent = 0x8a309e8, mNextSibling = 0x8a30e28, 
  mState = 8228}
(gdb) frame 0
#0  0x000004ec in ?? ()

ccing roc; I don't have a build with your latest patches, so maybe your
scrollbar changes for printing fixed this?
My latest build crashes with a completely different stack trace. I suspect
memory corruption unrelated to the issues I just fixed.
Assignee: printing → roc+moz
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
(Reporter)

Comment 4

15 years ago
Sure!  Sorry for the delay as I was actually shocked at which the speed of this
bug was picked up, and please do not take this wrong, since I've had others sit
quietly for months.

The incident ID's are as follows:

TB19471579K
TB19466369W
TB19466255X
TB19466203X

If I can provide anything else, please let me know...

Barry
My latest latest build works now. Argh! Barry, can you try today's nightly build
and see if this is working for you?

Comment 6

15 years ago
worksforme with linux trunk 20030429, but also 20030412.  perhaps the URL changed.
(Reporter)

Comment 7

15 years ago
I just proceeded with the D/L of the 20030430 build and attempted to reprint the
page from the URL.  Though from what I can recall, it appears the same but I
never saved a copy of the actual HTML.  What remains odd, even problematic, is
that after clicking print, having the printer dialog box appear and clicking ok,
the Printing dialog progress box 'stuck' and didn't go away while Windows still
shows the output spooling and the printer has printed page 6 of 6...  

Clicking the dialog close X, closes the box but does stop close the spooled job
within Windows (it thinks there is a page 7).  Efforts to print that page again,
produce another dialog stating: 'Printer Error: Not Available" even though I can
spool output to the printer from Mozilla mail or other apps, but they just won't
print because of the 'stuck' print job at the beginning...
*** Bug 205064 has been marked as a duplicate of this bug. ***
*** Bug 198414 has been marked as a duplicate of this bug. ***
*** Bug 190992 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
A few disparities between this bug and Bug 198414 (recent dupe)

- That bug was triggered without attempting to print
- That bug is Platform/OS : All/All

I'm not comfortable morphing this bug myself because I'm not conviced the dupe
was right. (same reason I wasn't quick to dupe 198414 to bug 156982)
*** Bug 223925 has been marked as a duplicate of this bug. ***
Summary: Printing this page crashes Mozilla and Phoenix → Printing this page crashes Mozilla and Phoenix [@ in nsLineBox::DeleteLineList]
Summary: Printing this page crashes Mozilla and Phoenix [@ in nsLineBox::DeleteLineList] → Printing this page crashes Mozilla and Phoenix [@ nsLineBox::DeleteLineList]

Comment 13

13 years ago
The page printed fine for me with 
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040916

Comment 14

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050423

no crash, but print preview doesn´t show the content (I can´t print here)
First page is showing the first table in the file, i.e. top banner with search box.
Second page is showing the second table, i.e. top menu and ad column/ index to
the right.

Third page does´t show third table, i.e. content, but only the print framework,
page number/date/URL etc.

Regarding the crash page is WFM, regarding printing there is something wrong
with the 2nd and 3rd page.
The google iframe on the page is missing the content, maybe that is responsible
 for not printing on the 2nd page?

For comparison another page, 2nd page ok, 3rd page missing content:
http://www.aceshardware.com/read.jsp?id=65000326

Comment 15

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050423
I found what stops the content from beeing seen in print-preview:

<center>
<center>
<table border=0 cellspacing=0 cellpadding=0 width=728 height=75>
<tr><td align=center> 
<!-- JavaScript Only -->
<script language="JavaScript1.1"
src="http://altfarm.mediaplex.com/ad/js/4340-23268-10185-0?mpt=[CACHEBUSTER]&mpvc=">
</script>
<noscript>
  <a href="http://altfarm.mediaplex.com/ad/ck/4340-23268-10185-0?mpt=[CACHEBUSTER]">
    <img
src="http://altfarm.mediaplex.com/ad/bn/4340-23268-10185-0?mpt=[CACHEBUSTER]"
alt="Click for Newegg.com's daily deals" border="0">
</a>
</noscript>
</td></tr></table>
</center>

</center>

That is an ad below menu and above content. It is seen only if JS is disabled.

If I remove this by making it comment, all of the page is seen correctly in
print-preview.

I saved the page as HTML only, replaced empty line 32 in the head with
<base href="http://www.aceshardware.com/">
The code above is located in lines 220 thru 236

Comment 16

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051217 Firefox/1.6a1

No more crash. -> WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsLineBox::DeleteLineList]
You need to log in before you can comment on or make changes to this bug.