Mozilla crashes; loses "Collected Addresses", filters, mail header format.

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Keith Jillings, Assigned: racham)

Tracking

({crash, dataloss})

Trunk
x86
Windows XP
crash, dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401

If I leave Mozilla running and the broadband connection open, and leave the
machine for over eight hours, Mozilla will sometimes crash when I try to read
mail on returning.  This crash locks up Win XP, and I have to reset the computer.

After reset, (a) the "collected addresses" folder has disappeared; (b) the mail
filters don't work; (c) e-mail addresses in the headers of incoming messages
don't display as clickable links (and aren't underlined).   Those addresses
can't be copied or pasted.

The fix (I found after long experimentation) is to close Mozilla, start Netscape
7.02, close Netscape 7.02, open Mozilla.   That fixes the links problem (c); 
the filters return (b) but are all turned off - they can't be turned on with the
"Tools - Filters - Edit" routine, but double-clicking each filter in turn resets it.

A new collected addresses list appears, but is blank (a).  It starts again
collecting addresses from scratch.  I've lost a few addresses that I should have
moved to one of my own address books that way!


Reproducible: Sometimes

Steps to Reproduce:
I have to leave the machine on, connected, and idle for 8 to 10 hours, and even
then it doesn't always crash when I return.   It's done this three times since I
installed 1.4a - it never did it prior to 1.4a.

Comment 1

15 years ago
Could you provide talkback incident ID of crash?
Keywords: crash, dataloss
Summary: Mozilla crashes; loses "Collected Addresses", filters, mail header format. → Mozilla crashes; loses "Collected Addresses", filters, mail header format.
(Reporter)

Comment 2

15 years ago
No talkback.   Win XP froze, and I had to reset the computer.

Comment 3

14 years ago
Unable to reproduce with Mozilla 1.7 beta on windows XP.  I leave Mozilla
running but idle for about 10-12 hours every single night and have experienced
no crashes returning to Mozilla mail in the morning with 1.7 beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.