Mozilla exits with code 11 when opening this site

RESOLVED DUPLICATE of bug 196484

Status

--
critical
RESOLVED DUPLICATE of bug 196484
16 years ago
14 years ago

People

(Reporter: davor.cubranic, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030315
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030315

Whenever I open this site today (25.4.), Mozilla crashes. (It's a news site that
I read every day and this has never happened before.) There are no error
messages, except exit code 11.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Changing the summary as Mozilla doesn't "crash", but rather exits when I open
the site. The shell reports exit code 11.
Summary: Crash when opening this site → Mozilla exits with code 11 when opening this site
Do you use a xft or gtk2 build ?
Do you have a talkback ID from that crash ?
Keywords: crash
(Reporter)

Comment 3

16 years ago
Sorry, I don't think our installation has talkback.
I believe it's XFT. (How come that's not specified in "About Mozilla" page?)

Java and Flash plugins are installed. If there is a way to disable them without
having write access to the installation directory, I can try turning them off to
see if that makes a difference.

Comment 4

16 years ago
are there any .fon (Microsoft) fonts on your system?  Are there any truetype
(ttf) fonts that are not world-readable?

can you grab a stacktrace with gdb?
Blocks: 198955
(Reporter)

Comment 5

16 years ago
Debugger backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 15909)]
0x40ed0500 in nsUnicodeEncodeHelper::ConvertByTable () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libuconv.so
(gdb) bt
#0  0x40ed0500 in nsUnicodeEncodeHelper::ConvertByTable () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libuconv.so
#1  0x40ed50f4 in nsTableEncoderSupport::ConvertNoBuffNoErr () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libuconv.so
#2  0x40ed4b77 in nsEncoderSupport::ConvertNoBuff () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libuconv.so
#3  0x40ed4d53 in nsEncoderSupport::Convert () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libuconv.so
#4  0x40fbffb4 in SingleByteConvert () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgfx_gtk.so
#5  0x40fc09da in nsFontGTKNormal::GetWidth () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgfx_gtk.so
#6  0x40fc3dc4 in do_BreakGetTextDimensions () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgfx_gtk.so
#7  0x40fbff5d in nsFontMetricsGTK::ResolveForwards () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgfx_gtk.so
#8  0x40fc401a in nsFontMetricsGTK::GetTextDimensions () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgfx_gtk.so
#9  0x40fad728 in nsRenderingContextGTK::GetTextDimensions () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgfx_gtk.so
#10 0x4084ba8f in nsTextFrame::MeasureText () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#11 0x4084c895 in nsTextFrame::Reflow () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#12 0x4081aa1f in nsLineLayout::ReflowFrame () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#13 0x40816f84 in nsInlineFrame::ReflowInlineFrame () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#14 0x40816c27 in nsInlineFrame::ReflowFrames () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#15 0x40816a94 in nsInlineFrame::Reflow () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#16 0x4081aa1f in nsLineLayout::ReflowFrame () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#17 0x40816f84 in nsInlineFrame::ReflowInlineFrame () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#18 0x40816c27 in nsInlineFrame::ReflowFrames () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#19 0x40816a94 in nsInlineFrame::Reflow () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#20 0x4081aa1f in nsLineLayout::ReflowFrame () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#21 0x407e8b44 in nsBlockFrame::ReflowInlineFrame () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#22 0x407e890e in nsBlockFrame::DoReflowInlineFrames () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#23 0x407e86df in nsBlockFrame::DoReflowInlineFramesAuto () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#24 0x407e858d in nsBlockFrame::ReflowInlineFrames () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#25 0x407e6fed in nsBlockFrame::ReflowLine () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#26 0x407e6746 in nsBlockFrame::ReflowDirtyLines () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#27 0x407e50c4 in nsBlockFrame::Reflow () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so
#28 0x407f399c in nsContainerFrame::ReflowChild () from
/.autofs/binaries/cslocallib/pkg/mozilla-1.3/lib/mozilla-1.3/components/libgklayout.so

[etc.]
(Reporter)

Comment 6

16 years ago
As far as .fon and .ttf fonts, I don't know if they are installed, but I turned
off the preference "allow documents to use other fonts" and the ones I use are
the standard X adobe-times, helvetica, and courier fonts.

Comment 7

16 years ago
based on the stack, you're seeing bug 196484, which has been fix since the
release of 1.3

*** This bug has been marked as a duplicate of 196484 ***
No longer blocks: 198955
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Workaround for this bug:
Start Mozilla like this:
% export MOZILLA_GFX_DISABLE_FAST_MEASURE=1
% ./mozilla
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.