links to file://localhost/.... don't work when index page is on a web server

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 84128
14 years ago
13 years ago

People

(Reporter: Jim Graham, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401

I've noticed a problem with the newer versions (not sure when it started) of
Mozilla that causes links to local directories to fail when the index file
they're in is served by a web server.  Example:  in my home network, my web
server is on my FreeBSD machine, and my main index pages are handled for all
of my systems by that machine.  There's a link in there to
file://localhost/d:/jdg/ (among others).  This works fine if I type it into
the address bar, or use a bookmark in Mozilla.

However....when that same address is served by the web server (or any other
web server I have write access to), it does nothing....  Middle-click doesn't
open the link in a new tab.  Right-click menus to open it in a new tab or new
window do nothing.  No error messages, etc...but also no new tab/window.



Reproducible: Always

Steps to Reproduce:
1. Create an HTML index file with a link to, e.g., file://localhost/d:/dirname/
2. Put that file on a web server and load from the server.
3. Click on the link.  Nothing happens.  Use right-click menu, middle-click,
etc....nothing happens.

Actual Results:  
Nothing.  No new page, no error, etc.

Expected Results:  
Open the link to the directory as it would if the index file were on the local
drive, and as it used to do regardless.
That's not new and this is also in the release notes.
(see the release notes how ti disable this and see tools/web
Development/Javascript Console for the error message )



*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.