[BLOCKER][CRASHER] Clicking on content(s) of listbox causes crash

VERIFIED DUPLICATE of bug 20042

Status

()

Core
Event Handling
P3
critical
VERIFIED DUPLICATE of bug 20042
18 years ago
18 years ago

People

(Reporter: ckritzer (gone), Assigned: rods (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:

Steps to Reproduce:
1) Launch seamonkey
2) Load http://marvin/ngdriver/tester.html
3) Click on "Find Suites in:" button
4) After listbox loads, click on any item in the listbox

Actual Results: Application crashes

Expected Results: List item is simply selected

Build Date & Platform Bug Found: MacOS86 1999113008 mozilla

Additional Builds and Platforms Tested On:
	Linux6 1999113008 mozilla

Additional Information:

Working on a simplified testcase w/desale.  Will add Windows findings soon.

Updated

18 years ago
Summary: [CRASHER] Clicking on content(s) of listbox causes crash → [BLOCKER][CRASHER] Clicking on content(s) of listbox causes crash

Comment 1

18 years ago
Actually having scrip hiding tags inside select is causing crash.

Submitting testcase.

STEPS TO REPRODUCE:
1] Please copy HTML code I'm providing. Save it as HTML file.
2] Open this HTML file with mozilla.exe with 11-29-09 builds.
3] You'll see one select. Click on any option of this select.

EXPECTED RESULTS:
We should be able to select any option.

ACTUAL RESULTS:
Application crashes.

TESTCASE CODE START:

<html>
<head><title>Select Test</title></head>
<body>
<form name="workform" >
<select multiple name=rundirectory size=4>
<!--This script hiding tag is causing crash-->
<option value=opt1>First Option</option>
<option value=opt2>Second Option</option>
<option value=opt3>Third Option</option>
<option value=opt4>Fourth Option</option>
<option value=opt5>Fifth Option</option>
<option value=opt6>Sixth Option</option>
</select><br>
</form>
</body>
</html>

TESTCASE CODE END:

ACTUAL PROBLEM:
If we take out line [<!--This script hiding tag is causing crash-->]from
testcase then everything works fine. This means having script hiding tags inside
select is causing application to crash.

I'm going to attach same testcase as attachment.

This bug is blocking our automation, so marking as BLOCKER.

Comment 2

18 years ago
Created attachment 3137 [details]
Same testcase attached.

Updated

18 years ago
Assignee: joki → rods

Comment 3

18 years ago
Man, this is a fun one.  Not due to the crash itself but the fact that it seems
to be caused by an html comment.  Cool.

Rod, you know far more about the internal structure of listboxes than I.
Since it seems to crash on a bad view in a listbox I'll let you have first
crack at this one.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

18 years ago
*** This bug has been marked as a duplicate of 20042 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Marking VERIFIED DUPLICATE per rods' comment.
You need to log in before you can comment on or make changes to this bug.