Implement smoothing in image scaling

VERIFIED DUPLICATE of bug 98971

Status

()

Firefox
General
--
trivial
VERIFIED DUPLICATE of bug 98971
15 years ago
15 years ago

People

(Reporter: Andrey Kislyuk, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030425 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030425 Mozilla Firebird/0.6

When an image is scaled to fit in the window in Phoenix, it often appears with
aliasing artifacts because of dumb (not averaging) resampling. Scaling is
properly done by weighted averaging all pixels corresponding to a pixel in the
scaled image. Also, a proper way to do this is like the MacOS X Viewer: first
draw the aliased image, then, when done averaging, re-draw with the smooth image.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 98971 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.