Eudora Import fails on folder names containing a slash

RESOLVED DUPLICATE of bug 131013

Status

--
critical
RESOLVED DUPLICATE of bug 131013
16 years ago
10 years ago

People

(Reporter: steve, Assigned: cavin)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Eudora allows folder and mailbox names to contain slashes (/).  Importing those
into Mozilla does not work.  Specifically, if the mailbox name has a slash
somewhere in the middle, the import will:
(a) create an empty folder in Mozilla, using that part of the Eudora name that
came after the slash;
(b) report (in the summary at the end) that it was unable to import the folder.

Much worse, however, is if the Eudora name *starts* with a slash.  In this case,
the Mozilla import hangs, eating up more and more virtual memory until the
system is driven to its knees.  You have to kill Mozilla manually to get out of
this.  After restarting Mozilla, there is folder whose name is a hexadecimal
value in the place where the import should be.  Attempting to delete this folder
also causes Mozilla to hang and eat VM until you kill it.

Reproducible: Always

Steps to Reproduce:
1. In Eudora, create a mailbox with a name starting with a slash.
2. Import from Eudora to Mozilla.
Actual Results:  
Mozilla stopped partway through the import process, and became unresponsive. 
The disk continued to run wildly, and task manager showed that memory usage by
Mozilla was growing rapidly and monotonically.  After waiting for 30 minutes of
this, I killed it.

Expected Results:  
Preferred: import the folder with the name intact.  (Slash is a useful character
in folder and mailbox names.)
Failing that: import the folder with the slash omitted from the name.
At a minimum: don't hang.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 131013 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.