Closed Bug 203608 Opened 18 years ago Closed 18 years ago

Width property in style attribute not changing size of input box for input type file

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 52500

People

(Reporter: gyoung, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126

If I assign a width property in a style attribute or css class and apply to an
input element of type "file" in a form, the layout accomodates the width (as
shown by the * and description placed after each input box), but the input
box/button do not scale accordingly.  Same problem occurs if width specified
using CSS class.

The page includes a screenshot of IE6 handling of the same page (which is the
expected behaviour).


Reproducible: Always

Steps to Reproduce:
See http://www.macromanage.com.au/mozilla/fileuploadwidth.html



Expected Results:  
See IE screenshot at http://www.macromanage.com.au/mozilla/fileuploadwidth.html
form controls...
Assignee: dom_bugs → form
Component: DOM Style → Layout: Form Controls
OS: Windows 2000 → All
QA Contact: ian → desale
Hardware: PC → All
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.