Last Comment Bug 203609 - Viewing the above URL displays the word concat instead of the real text that was there which is open.
: Viewing the above URL displays the word concat instead of the real text that ...
Status: RESOLVED DUPLICATE of bug 175201
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
-- critical (vote)
: ---
Assigned To: Asa Dotzler [:asa]
: Asa Dotzler [:asa]
:
Mentors:
http://davesource.com/Bugs/mozilla.2....
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-27 19:52 PDT by Steven W. Orr
Modified: 2004-11-22 17:25 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Steven W. Orr 2003-04-27 19:52:57 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

I looked at a perl script which calls open. Every occurance of the word open is
replaced with the 
word concat. Everything else is correct. We reduced the problem down to a
minimal example using the above URL. If I fetch the file using lynx I see open.
If I use mozilla I see concat.

Reproducible: Always

Steps to Reproduce:
1.Visit the above URL
2.Look at the work in line 2.
3.It will display concat even though the file on the server says open.

Actual Results:  
I see concat.

Expected Results:  
It should have displayed open.

Sorry. none.
Comment 1 User image Steven W. Orr 2003-04-27 20:09:36 PDT
I tried viewing the file locally and the open displayed as open. It only failed
for me by displaying concat using the above URL

http://davesource.com/Bugs/mozilla.2.example
Comment 2 User image Boris Zbarsky [:bz] (still a bit busy) 2003-04-27 22:45:36 PDT
Worksforme on that URL with a current build.... Does clearing the cache help?
Comment 3 User image Torben 2003-07-24 03:42:52 PDT
This is probably caused by a filtering proxy like privoxy, see bug 175201.
Comment 4 User image Steven W. Orr 2003-07-24 06:40:38 PDT
This is confirmed. It is privoxy that is causing the problem. The lastest
version of privoxy also dos it but differently. (Instead of open ==> concat it's
open ==> some privoxy_prefix_concat.

Does this bug need to be reopened as a privoxy bug or does a new bug get created?
Comment 5 User image Boris Zbarsky [:bz] (still a bit busy) 2003-07-24 08:50:31 PDT
It gets marked duplicate of the existing bug....

privoxy is doing exactly what it's designed to do, if I understand what it does
correctly... perhaps it has a setting to turn off this behavior.

*** This bug has been marked as a duplicate of 175201 ***

Note You need to log in before you can comment on or make changes to this bug.