Closed Bug 203675 Opened 17 years ago Closed 5 years ago

File URL documentation

Categories

(Documentation Graveyard :: Help Viewer, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX
mozilla1.7alpha

People

(Reporter: benc, Assigned: benc)

Details

I have found it necessary to write some minimal technical documentation, partly
for QA purposes, preventing bugs, explaining larger issues.

It might be time, based on the number of comments in bug 66194 to write
something about the general behavior of the file: URL protocol handler, and how
file URLs address the variety of local filespaces they see.

GROUND RULES:
The goal is deciding what should be documented. Bugs need to be filed agasint
the Networking:File component (there are no developers here).
I think we should open up new bugs as tracking bugs documenting certain
features, explaining some decisions. Do not use old, cluttered bugs for that,
the information gets lost in the comments. If necessary make references to the
documentation bug in other bugs.
Ben, I am not familiar with file URL, but if you can draw up
a list of issues that the doc should cover, bug links, and
hints to where in the source code the information may be
buried, I may be able to hack a draft to get this bug going
(of course, if someone more knowledgeable than I am want to
volunteer, all the better). The draft will be LXR-oriented
so the person can take over quickly.

related interface? nsILocalFile (is there a relative file
interface?), nsIFileSpec
andreas:

Agreed, in this case however, the result would be a me taking a list of
suggested bugs, and writing a document for mozilla.org (this is not a bug that
claims it is documentation).

Here's a list of bugs I think would be good material.

13607   "file:///" shows blank page instead of root (Mach-O & Win)
47009   file: no read permissions should error
65152   "file://" -> "file:///" 
70871   file://hostname/dir/dir/filename - hostname not implemented 
102603   file: "?query" is ignored, rather than treated as part of filename
122022   [ISSUE] file:// URLs in a http | https page do not work (clicking does
nothing, do not auto-load, etc.) [dupe to bug 84128]
143021   Local files w/ relative file URLs need to have a drive letter.
197283   Mozilla 1.3f (Mach-O) breaks previous (CFM ) created file: URLs (esp.
in bookmarks)

I had tried to document this before, and found the draft was kind of unreadable,
but I think I can do a better job of explaining now.
Moving all of rudman's bugs to me, the new owner of Doc: User.
Assignee: rudman → rlk
QA Contact: rudman → stolenclover
Ben, how're you doing lately? Do you wanna take this bug? Maybe post your draft
so we can post suggestions?
Still on my todo list, but unlikely to have draft until Feb.

DNS has become a higher priority for now.
Assignee: rlk → benc
Target Milestone: --- → mozilla1.7alpha
This bug has been buried in the graveyard and has not been updated in over 10 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.