Problem with writing greek text in mozilla

VERIFIED DUPLICATE of bug 176514

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 176514
15 years ago
15 years ago

People

(Reporter: Nikos Charonitakis, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

when i  type greek text in mozilla (text boxes,address
area,composer,everywhere...) i cant put accents
to letters that uses them.
I use RedHat linux9 and i dont know if this problem is specific to
mozilla1.2.1,red hat's mozilla build or xkb or something else.
I dont have such a problem using other applications (even gtk2 apps work by
chosing x input method when a type greek text).
In the past i have never a similar problem with mozilla.
Note:to put an accent on a greek letter we  first type the key[;](right to L)
and then we type type the letter.


Reproducible: Always

Steps to Reproduce:
1.type greek text
2.put an accent on a letter
3.

Actual Results:  
I see this ->->-> 'a 'e 'o etc (say that a, e, o are letters from greek alphabet)

Comment 1

15 years ago
1.2.1 is very old, did you try it with a recent build?
(Reporter)

Comment 2

15 years ago
no i havent try a newer because i dont know which build to try without
breaking things in my installation(you know gtk2 etc)
are there any stable builds for rh9 to try?
Are you using a gtk2 build of 1.2.1?
(Reporter)

Comment 4

15 years ago
yes it's a gtk2 build and uses fontconfig for getting fonts.
Intl text entry is broken in gtk2 builds in general; we have dozens of bugs on
that (all but one resolved duplicate, of course).
Assignee: smontagu → blizzard
Whiteboard: DUPEME
(Assignee)

Comment 6

15 years ago
Fixed in recent builds.

*** This bug has been marked as a duplicate of 176514 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 7

15 years ago
Mark as verified as dup.  Please re-open if still see the problem on latest
trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.