UL, etc. left margin vs. padding

VERIFIED FIXED in M11

Status

()

P2
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: dbaron, Assigned: peterl-retired)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I noticed in ua.css you have 40px of margin-left on UL, DIR, MENU, and OL.  I
think it would be better to make this padding, because of drawing background-
colors or borders on ULs and placing them next to paragraphs.  If it is margin,
then it would be unknown on which side the bullets would fall - it would depend
on the LI box properties.  I think padding makes more sense, even though it is
not what is suggested in http://www.w3.org/TR/REC-CSS2/sample.html .
Perhaps the list indentation should be on the LI's margin rather than the UL's
padding.  That would solve the inside/outside bug as well.

However, I think UL padding or LI margin are the only two good alternatives.  I
think UL margin is bad.  Then a background wouldn't get the bullets... and
borders would be messy.

Comment 3

20 years ago
Setting all current Open/Normal to M4.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M4 → M7
*** Bug 1363 has been marked as a duplicate of this bug. ***
You may also want to have this padding (or margin, if you insist) in em units
rather than px.
(Assignee)

Updated

20 years ago
Target Milestone: M10 → M11
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

20 years ago
Changed lists to use padding for indents. This isn't quite backward compatible,
but it's better than what we had before (and probably better for the authors
this way).

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 8

20 years ago
Using 9/16 Apprunner with attached test case, verified fixed. Padding now used
for indents and page displays with list indicators inside box.
You need to log in before you can comment on or make changes to this bug.