Last Comment Bug 203868 - modutil -delete does not delete modules that it cannot load
: modutil -delete does not delete modules that it cannot load
Status: RESOLVED DUPLICATE of bug 203866
:
Product: NSS
Classification: Components
Component: Tools (show other bugs)
: 3.8
: x86 Windows 2000
: P2 major (vote)
: 3.9
Assigned To: Robert Relyea
: Bishakha Banerjee
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-29 18:58 PDT by Nelson Bolyard (seldom reads bugmail)
Modified: 2003-10-09 09:40 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Nelson Bolyard (seldom reads bugmail) 2003-04-29 18:58:57 PDT
The command
modutil -delete <module_name>
should delete the named module if it exists in the secmod.db file,
whether or not it is able to load the module's shared library. 

But today, modutil will erroneously state that there is no such module
in the DB if it cannot load the module.  

This makes it impossible to delete modules from secmod.db after they've
been uninstalled.
Comment 1 Nelson Bolyard (seldom reads bugmail) 2003-09-25 20:48:46 PDT
retarget for NSS 3.9, since this wasn't fixed for 3.8.1
Comment 2 Wan-Teh Chang 2003-10-02 15:00:11 PDT
Bob, could you take a look at this modutil bug?  Thanks.
Comment 3 Robert Relyea 2003-10-09 09:40:32 PDT
The patch to fix bug 203866 will fix this problem as well.


*** This bug has been marked as a duplicate of 203866 ***

Note You need to log in before you can comment on or make changes to this bug.