Mozilla crashes when viewing Viewer Demo #9 Frames in Print Preview

RESOLVED DUPLICATE of bug 195721

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 195721
15 years ago
13 years ago

People

(Reporter: José Jeria, Assigned: asa)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030429

Go to Viewer Demos #9 and then Print Preview --> crash

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

15 years ago
Keywords: crash
(Reporter)

Updated

15 years ago
Severity: normal → critical
Keywords: regression
dupe of bug 195721 (who is the reporter of this bug ?)


*** This bug has been marked as a duplicate of 195721 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
:-)
Matti, is it really the same bug? The other one I reported is about reloading
with the contextmenu, this one crashes before entering print preview...
07b7a733()
nsGfxScrollFrame::Destroy(nsGfxScrollFrame * const 0x080f96a0, nsIPresContext *
0x04b15778) line 457
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x00000000, nsIPresContext *
0x04b15778) line 143
nsBoxFrame::Destroy(nsBoxFrame * const 0x080f93dc, nsIPresContext * 0x04b15778)
line 1103 + 9 bytes
nsTextControlFrame::Destroy(nsTextControlFrame * const 0x080f93dc,
nsIPresContext * 0x04b15778) line 1291 + 10 bytes
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x00000000, nsIPresContext *
0x04b15778) line 143
nsLineBox::DeleteLineList(nsIPresContext * 0x04b15778, nsLineList & {...}) line
306 + 10 bytes
nsBlockFrame::Destroy(nsBlockFrame * const 0x08116de4, nsIPresContext *
0x04b15778) line 423 + 10 bytes
nsLineBox::DeleteLineList(nsIPresContext * 0x04b15778, nsLineList & {...}) line
306 + 10 bytes
nsBlockFrame::Destroy(nsBlockFrame * const 0x08116e64, nsIPresContext *
0x04b15778) line 423 + 10 bytes
nsLineBox::DeleteLineList(nsIPresContext * 0x04b15778, nsLineList & {...}) line
306 + 10 bytes
nsBlockFrame::Destroy(nsBlockFrame * const 0x08116ee4, nsIPresContext *
0x04b15778) line 423 + 10 bytes
nsLineBox::DeleteLineList(nsIPresContext * 0x04b15778, nsLineList & {...}) line
306 + 10 bytes
nsBlockFrame::Destroy(nsBlockFrame * const 0x0811701c, nsIPresContext *
0x04b15778) line 423 + 10 bytes
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x07e3e9b0, nsIPresContext *
0x04b15778) line 143
nsPositionedInlineFrame::Destroy(nsPositionedInlineFrame * const 0x08116fcc,
nsIPresContext * 0x04b15778) line 1143 + 10 bytes
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x07e3e938, nsIPresContext *
0x04b15778) line 143
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x07b2b0a8, nsIPresContext *
0x04b15778) line 143
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x07b56548, nsIPresContext *
0x04b15778) line 143
nsBoxFrame::Destroy(nsBoxFrame * const 0x07f3e6e8, nsIPresContext * 0x04b15778)
line 1103 + 9 bytes
nsFrameList::DestroyFrames(nsFrameList * const 0x07d9d020, nsIPresContext *
0x04b15778) line 130 + 13 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x07518c30, nsIPresContext *
0x04b15778) line 143
nsPositionedInlineFrame::Destroy(nsPositionedInlineFrame * const 0x07f3e498,
nsIPresContext * 0x04b15778) line 1143 + 10 bytes
FrameManager::Destroy(FrameManager * const 0x07518b88) line 517
PresShell::Destroy(PresShell * const 0x00000000) line 1841
nsPrintObject::DestroyPresentation(nsPrintObject * const 0x07d9d020) line 110
nsPrintEngine::SetupToPrintContent(nsPrintEngine * const 0x07

note: The top is a little bit different because I'm using a optimized build with
symbols and not a debug build and possible due to small code changes..

The "about:config" URL print preview crash is also the same 
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.