unable to retrieve messages, warning "current folder is being processed, ....", and mail doesn't want to be retrieved

RESOLVED DUPLICATE of bug 152675

Status

MailNews Core
Backend
--
major
RESOLVED DUPLICATE of bug 152675
15 years ago
10 years ago

People

(Reporter: £ukasz Mach, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030430
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030430

i have mail folder (Local directory at "Mail & Newsgroups Preferences"->my
account->"Server Settings") set at /_/c/some_folder , where /_/c is my mount
point to windows fat32 partition. Under windows, this is set to "c:\some_folder". 
When i start mozilla -mail, it retrieves messages properly. next, after 10
minutes, it retrieves again. also properly too. in next few retrieves, warning
shows:"Current folder is being processed. Please wait until processing is
complete to get messages", and no more retrieval until mozilla restarted. It
happends in all versions of mozilla from 1.3 to current nightly build

Reproducible: Always

Steps to Reproduce:
1.Create mail account. 
2.Go to account preferences window, open Server Settings, remember in your mind
local directory as DIR1, and change local directory to some directory located on
vfat partition(remember in your mind as DIR2).
3.close mozilla.
4. copy all files from DIR1 to DIR2
5. launch mozilla
6. set mail retrieve period to some time(in my machine, 10 minutes), and check
"Automatically retrieve new messages" option.
7. wait for warning.
4.copy all files located in mail 

Actual Results:  
Warning:"Current folder is being processed. Please wait until processing is
complete to get messages". no mail is retrieved

Expected Results:  
no warning, mail should be retrieved.

tested on all versions of mozilla from 1.3 to current.
linux: glibc 2.3.2, linux 2.4.20, mount vfat
(rw,gid=1000,umask=000,dmask=111,showexec)

windows: windows XP, windows 2000.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 152675 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Lukasz -- are you using attbi mail?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.