Layout errors with css 2.x concerning inline/inline-block and <span>

RESOLVED DUPLICATE of bug 9458

Status

()

RESOLVED DUPLICATE of bug 9458
16 years ago
16 years ago

People

(Reporter: sven, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Concrning the span thing, I can create another page, but it seems ot be a
general layout problem, which applies to all kinda things:

if you look at the page (url) above, you will see a dark blue box, with green
text and a picture. Since the box is a Paragraph and has display: inline-block
set, it should wrap around the picture, since all contents should be treated as
being in a box element:

css spec:

"inline-block
    This value causes an element to generate a block box, which itself is flowed
as a single inline box, similar to a replaced element. The inside of an
inline-block is formatted as a block box, and the element itself is formatted as
a replaced element on the line."

Second:

the light blue box is a div, which is an inline-block element too. If I set a
height to the paragraph inline-block box, it gets resized and wraps it, as I
expect it, so this doesn't seem to be broken, but it should be treated as inline
element. since the div's width is smaller, than the surrounding one, and is
defined as inline-block, which means, it should be treated as an inline element,
the surrounding's div text-align property (in this case center) should apply.

css-spec:

"When the total width of the inline boxes on a line is less than the width of
the line box containing them, their horizontal distribution within the line box
is determined by the 'text-align' property. If that property has the value
'justify', the user agent may stretch the inline boxes as well."


Reproducible: Always

Steps to Reproduce:
1. Just load that page
2.
3.

Actual Results:  
well, the layout is kinda 'screwed' up.

Expected Results:  
I expect the Paragraph to wrap the picture, the div inside the div to wrap the
paragraph and be centered.
Well... all this would be true if we implemented inline-block.  :)

*** This bug has been marked as a duplicate of 9458 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.