url for jpeg image with no .jpg extentsion causes crash

RESOLVED DUPLICATE of bug 173204

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 173204
15 years ago
13 years ago

People

(Reporter: Britt Cleveland, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030430 Debian/1.3-5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030430 Debian/1.3-5

Attemping to visit this url causes mozilla to crash.

Reproducible: Always

Steps to Reproduce:
1.paste in url
2.hit enter
3.

Actual Results:  
instant crash

Expected Results:  
If not display the image, at least not crash.


I got the file with wget, renamed to 39130650101-30.jpg and mozilla could
display it off the local disk.

Comment 1

15 years ago
The link is a text document as far as Mozilla knows becuase it was sent a
Content-type: text/plain.
Did not crash WFM LInux 2003042807 nightly

Comment 2

15 years ago
this is probably an XFT-related problem (worksforme with linux trunk 20030430),
bug 173204 or maybe bug 175108.  both are not Mozilla's fault, bug 175108 has
been fixed since the release of 1.3

marking dupe.

*** This bug has been marked as a duplicate of 173204 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.