Closed Bug 20416 Opened 20 years ago Closed 20 years ago

[dogfood] Running Seamonkey prevents Communicator 4.7 from making TCP connections

Categories

(Core :: Networking, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: chriss, Assigned: warrensomebody)

Details

(Whiteboard: [PDT-])

Build ID: 1999113012
Steps to reproduce:

1) Launch Communicator 4.7
2) Launch Seamonkey and display a page
3) Wait 1 minute
4) Try to open a new (uncached) web site in 4.7 - notice this dialog box:
"A network error occured: unable to connect to server (TCP error: not enough
memory). The server may be down or unreachable."
5) Quit Seamonkey
6) Attempt to open new web page again in 4.7 - notice that it now works

I'm running Windows 98 and a Pentium with 160MB. Other apps that are running
include Calendar and AIM.

This is an interesting dogfood bug in that it doesn't prevent me from using
Seamonkey directly, but discourages me from using it as dogfood as I need to
have 4.7 running to do the things that Seamonkey can't. Also note that I can't
send email from 4.7 because of the same TCP error.
Assignee: leger → gagan
Component: Browser-General → Networking-Core
QA Contact: leger → tever
tever, do you see this when running the 4.71 and Seamonkey at the same time?
I think this bug is related to
http://bugzilla.mozilla.org/show_bug.cgi?id=20419

It also appears to be caused by a memory leak since the problem appears over
time after launching seamonkey.
Adding warren@netscape.com and beard@netscape.com to cc: list per conversation
with warren.
Whiteboard: [PDT+]
Putting on PDT+ radar.
FWIW I installed a win98 app called memory+ to monitor memory use.

Based on what it is reporting, I don't see a memory leak. Basically seamonkey is
using about 16MB of physical memory and 22MB of virtual memory and it's more or
less steady at least over the time period that I notice the above problems.
Assignee: gagan → warren
Assigning to myself since Gagan isn't here.

Chris: I might have to come by tomorrow to play with your machine since I don't
have a win98 box.

Rick/Jud: Any ideas?
unfortunatley TCP errors in 4.x are all but meaningless :(. There are instances
in 4.x in which DNS (at the TCP stack level) can be adversly affected, but I
don't think it's possible to get TCP errors in 4.x because of DNS issues. But,
that's really the only shared resource between the two.?.? :-/
Target Milestone: M12
jan, I havn't been able to reproduce this on NT.  I don't have Win98 but I
believe paulmac checked it on that OS.  There must be something unique about the
original system causing this.
I just tried to reproduce this on a Win98 box running in Waterson's cube, but
with no luck. I didn't see the problem in mozilla or seamonkey, even while
running aim. We're going to have to debug it on chriss' machine.

Could this be related to bug 19114?
Rick and I determined that it's not a memory leak problem or related to
19114, but is because we're getting a NS_ERROR_CONNECTION_REFUSED error from
the socket transport for some reason. Rick is investigating...
As of the 199120808 build, this problem has gone away for me. Warren - did you
check in a fix or do something special to my machine?
Moving what's not done for M12 to M13.
Whiteboard: [PDT+]
Removing PDT annotation to get re-eval (hopefully PDT- since it only impacts one
machine).
Whiteboard: [PDT-]
Putting on the PDT- radar. Only happening on chriss machine.
Blocks: 21564
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
Chris: You said this problem went away for you, right? If so, can we mark this
WORKSFORME now? I'm not sure what else to do to try and track it down.
yes - let's mark works for me.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Can't reproduce.
can not reproduce myself, works for original reporter - marking verified
Status: RESOLVED → VERIFIED
No longer blocks: 21564
You need to log in before you can comment on or make changes to this bug.