Browser loses track of previous position when going back to URL with anchor

RESOLVED DUPLICATE of bug 204364

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 204364
15 years ago
13 years ago

People

(Reporter: Per Ångström, Assigned: asa)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
If I have followed a URL with an anchor and I then follow a link and return back
again, Mozilla will lose track of where I was on the page - I will always end up
at the top of the page, having to reload the page or manually my previous position. 

If I had followed the same link from a non-anchored URL Mozilla would have
returned to my previous position. 

Seen in Mozilla Firebird/0.6-20030429 and Mozilla 1.4b-20030502 on Linux, and
Mozilla 1.4b-20030502 on Windows 98. I think this is a quite recent regression.
Netscape 7.02 doesn't have this annoying behaviour.

Instructions on how to reproduce the bug will be posted in a comment.
(Reporter)

Comment 1

15 years ago
How to reproduce:
1) Follow this link: http://bugzilla.mozilla.org/show_bug.cgi?id=204366#c0
2) Scroll down as far as possible.
3) Now follow this link: <http://www.mozilla.org/> and go back to the previous
page (using the back button or equivalent).
4) Note where the browser returns to.

Expected result:
The browser should return exactly to where I was before following the link to
another page.

Actual result:
The browser returns to the top of the page.

The problem is 100 % reproducible.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 204364 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.