local path probably handled incorrectly

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: leo mantovani, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

Stylesheets are present in /styles dir (drive is intentionally omitted).
<head>
  <link href="/styles/swdev.css" rel="stylesheet" type="text/css">
  <link href="/styles/private_header.css" rel="stylesheet" type="text/css">
</head>
MSIE uses the css correctly, Mozilla (and Opera ;-), don't use them.
The same problem is present for images link too (e.g. <img
src="/Images/back.gif">, but it is not present for links to *current* dir, that
is when stylesheets and img are in the current dir.

Reproducible: Always

Steps to Reproduce:
1. put css and images in c:\StyleImg
2. create an html page on the same drive, e.g. in c:\test
3. include the css and the img in the page using absolute path without drive,
/styleimg/test.css and /styleimg/test.png

Actual Results:  
The image is now viewed and css not used

Expected Results:  
Show the image and use the css.
I would expact that the "/" path (root) is internally expanded to
<same_drive_of_the_html_page>\, i.e. c:\
When the document is placed on the web, the / path should be expanded to the web
root.
At least this is the behaviour with MSIE ;-)

Both browser and composer are affected by this.

I currently use a wysiwyg editor and than publish pages, and to share icons and
stylesheets among the tons of documents I found this simple way, i.e. to put
shared css and images in a couple of dirs referenced from root (either website
root or disk root).
I would like to use composer, which is easy and powerful at the same time and
seems to generate a clean html code, but I'm blocked because of this behaviour.

I also use Linux mdk (Mozilla 1.3), and there is identical problem.
> I would expact that the "/" path (root) is internally expanded to
> <same_drive_of_the_html_page>\, i.e. c:\

That's in fact exactly NOT what the URL specification says should happen. 
Mozilla and Opera follow the url spec, IE does its little windows-centric thing....

/c|/ is what c:\ would be as a url.  (Consider that it makes no sense for /d| to
not be a sibling of /image.gif .)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.