Filtering will not always catch text in the body of a message.

RESOLVED DUPLICATE of bug 204322

Status

RESOLVED DUPLICATE of bug 204322
16 years ago
10 years ago

People

(Reporter: tom, Assigned: naving)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

The filtering appears to catch text like "http://www.anydomain.com" in a plain
text message but no in a HTML message that contains "http://www.anydomain.com".
 Same filter, two different message types.  It appears that no matter what text
I search for I get the same results.  In my case I am tring to filter messages
that contain a website address nad it works fine on text messages but not HTML
messages.

Reproducible: Always

Steps to Reproduce:
1. Create the filter for the body to contain http:// and Label it Important
2. take a text message and run it through the filter - works fine
3. take a HTML message and run it through the filter - does NOT work

Actual Results:  
The filter fails to process the HTML message..

Expected Results:  
Should have labeled the message important

Comment 1

16 years ago
Tom Cosimano: if you agree this is a duplicate, please mark this bug as 
Verified.

*** This bug has been marked as a duplicate of 204322 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.