The result of running JavaScript is not correct.

VERIFIED WONTFIX

Status

Rhino
Core
VERIFIED WONTFIX
15 years ago
14 years ago

People

(Reporter: Min Sun, Assigned: Norris Boyd)

Tracking

other
1.5R5
x86
Windows 2000

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

I have the JavaScript below:
if(APPL._event== 'CYBER.NIGHTS')
       APPL.startafter=4;
  else 
       APPL.startafter=8;

The result should be 8(if else is chosen)instead of 8.0.
The result of 8.0 only happens when optimization settings is -1.

Reproducible: Always

Steps to Reproduce:
1.Context threadContext = Context.enter();
2.threadContext.setOptimizationLevel(-1);
3.run JavaScript.

Actual Results:  
APPL.startafter=8.0

Expected Results:  
APPL.startafter=8

This can reproduce by using Rhino 1.5R4.1.

Comment 1

15 years ago
cc'ing Igor -

Comment 2

15 years ago
What is APPL and what is _event?

How that 8.0 was obtained?

Without this answers it is not possible to tell anything about it.

Comment 3

15 years ago
No user input to reproduce the bug, closing as wontfix ( is this the right way
to deal with such situation?)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
Marking Verified. (I usually mark such reports as "WORKSFORME", 
since no clear bug was indentified that needed fixing.)

msun@cybermation.com: if you can provide more information (see Comment #2), 
please reopen this bug and we will be happy to look at it -
Status: RESOLVED → VERIFIED

Comment 5

14 years ago
Targeting as resolved against 1.5R5
Target Milestone: --- → 1.5R5
You need to log in before you can comment on or make changes to this bug.