Closed Bug 204845 Opened 17 years ago Closed 16 years ago

http://localhost/ redirected to localhost.net.au

Categories

(Firefox :: General, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 178123

People

(Reporter: wim.paulussen, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

I run an Apache/PHP/MySQL application on my local machine. I saved a bookmark to
the following address http://localhost/myadm/index.php ( = phpMyAdmin index
location). I tried to use the bookmark and was relocated to the following url 
http://www.localhost.net.au, although the web server was not running. I suppose
it should give a message that it cannot reach the page , rather than redirecting
to a totally different site.

Reproducible: Always

Steps to Reproduce:
1. bookmark a page on the localhost
2. stop the Apache web server on the local machine
3. open the bookmark

Actual Results:  
I cannot reach the web pages on the local webserver (Apache) because the
webserver is stopped , but get redirected to a url that I did not bookmark

Expected Results:  
give a notification that the page is not reachable (unless you have stock in
localhost.net.au)

I use the Modern theme but think this is irrelevant.
I work with the following browsers : IE , Opera , Mozilla ( since recently
switched to Phoenix)
Confirming as I could reproduce w/ Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
-> NEW
-> All
-> General
Changing summary.

More easy way to reproduce:
If your computer doesn't run web service, just click the link
http://localhost/

Actual Results:  
Mozilla Firebird redirected to http://www.localhost.net.au/

Expected Results:  
Error message 
"The connection was refused when attempting to contact localhost."
should be shown as mozilla.
Assignee: chanial → blaker
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: Bookmarks → General
Ever confirmed: true
OS: Windows 2000 → All
Summary: when saving a localhost web page , it does not get saved correctly → http://localhost/ redirected to localhost.net.au
This is a feature.
It uses Googles's "I'm feeling lucky".
Set the the "keyword.enabled" pref to false if you don't want this.
as a matter of fact, this is bug 184433

*** This bug has been marked as a duplicate of 184433 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
REOPEN: linking issue to a Firebird specific bug (this bug has two possible
solutions.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 178123 ***
Status: REOPENED → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.