Problems with accessing LDAP over SSL

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: mikeypotter, Unassigned)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Mozilla version 1.3, also tested with Mozilla 1.4 beta

When trying to access contacts from our new homebase anywhere service over SSL,
I can only search once.  It will return results for that search, but when I try
to search again, it fails.  When I close the browser, I get the following alert
message:
"The operation can not be completed because of an internal failure. A secure
network coummnication has not been cleaned up correctly."
The following gets dumped to the terminal: 
(<unknown>:17045): Gtk-CRITICAL **: file gtkmain.c: line 994 (gtk_main_quit):
assertion `main_loops != NULL' failed

Steps to reproduce:
1. Go to http://homebase.oeone.net and sign up for a new HomeBase account.
2. Follow the instructions at http://www.oeone.com/phpbb/viewtopic.php?t=16 to
set your contacts up in Mozilla address book.
3.  (Restart Mozilla. This is needed in Mozilla 1.3, don't know about the latest
nightly)
4. Go to contacts, and do a search for *.  Notice you get results back.
5. Clear the search.
6. Do a search for * again.  Notice you get nothing back.
7. Quit Mozilla.  You should get the alert error message.

Updated

14 years ago
Blocks: 219087
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
No longer blocks: 219087
Reporter, could you try this with a current version of Thunderbird or SeaMonkey?  you may still get the error on exit, but you should be able to search more than once.

Comment 2

13 years ago
I'm using thunderbird 1.5.0.4 on OS X and have setup openldap with ssl/tls only. I get the same thing when i close thunderbird after using the ldap.

Alert

The operation can not be completed because of an internal failure. A secure network communication has not been cleaned up correctly.
(In reply to comment #1)
> Reporter, could you try this with a current version of Thunderbird or
> SeaMonkey?  you may still get the error on exit, but you should be able to
> search more than once.

No response from the original reporter after request for more information therefore I'm closing this as WFM as I have not seen or heard of any other crashes of this type.

(In reply to comment #2)
> I'm using thunderbird 1.5.0.4 on OS X and have setup openldap with ssl/tls
> only. I get the same thing when i close thunderbird after using the ldap.
> Alert
> The operation can not be completed because of an internal failure. A secure
> network communication has not been cleaned up correctly.

This problem was covered by bug 206018 and isn't to do with this bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.