a horizontal rule <hr> extends through an image

RESOLVED DUPLICATE of bug 84887

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 84887
15 years ago
15 years ago

People

(Reporter: Michael Conti, Assigned: roc)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

A horizontal rule <hr> extends through an image instead of stopping at the start
of an image. It displays correctly on IE 5 & 6 and Netscape 4.79 and Opera 6.
Incorrectly on Netscape 7 and Mozilla.

Reproducible: Always

Steps to Reproduce:
1.Look at the URL: www.computers4seniors.org
2.
3.

Actual Results:  
<hr> extensd across image on the right

Expected Results:  
<hr> should stop at image as it does on Netscape 4, IE and Opera

Comment 1

15 years ago
Not sure if this is a dupe, but looks to be related to doctype declaration
(quirks?).  Attaching a reduced testcase.

Comment 2

15 years ago
Created attachment 122856 [details]
Testcase showing hr through the image.

Comment 3

15 years ago
Created attachment 122859 [details]
Simplied test-case

I've attached a test case.  The problem seems to go away if you remove
align="right".

Comment 4

15 years ago
This may be a dupe of bug 84887.  Removing align=right may fix it, but so does
removing the doctype declaration.  I just don't know whether having it there
puts Moz in standard or quirks mode.

Updated

15 years ago
Keywords: testcase

Comment 5

15 years ago
You can see which mode is used in Page Info (CTRL+I)

*** This bug has been marked as a duplicate of 84887 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.