Macho build needs to handle CFM based local bookmarks

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
--
major
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Chris Petersen, Assigned: janv)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

15 years ago
Ben asked me to file a bug regarding CFM based local boomarks and how the Macho
version treats them. The bug will help described why this problem is occuring.


The CFM version was in many ways the just like Mac OS 9, it looked at
the file system as a set of disk drives. So file URLs would say:

file:///Macintosh%20HD/Users/

If you use the open file command to pick a file, then look at the URL,
you'd find that CFM and Mac OS 9 used the same format.

Mac OS X is, at the heart, UNIX based, and Mach-O is a true UNIX
application. It (as most Mac OS X browsers like IE, Omniweb, and
Chimera/Camino) look at the filesystem as a UNIX-style tree.

So the same location would have a different file URL:

file:///Users/

The easiest way to reproduce this is to bookmark some file URLs in
Mozilla, then open the same profile in a recent Mach-O build and try
to use the bookmark.

It will fail, (because in UNIX that path doesn't exist). Mac OS X's
finder does not highlight this change, so if this is confusing, run the
"Terminal.app" in /Applications/Utilities/ and poke around in the UNIX
shell. If you type:

ls -l

you would see that the filesystem shows no "Macintosh HD" (because that
drive volume is mounted as "/".

What is being proposed, and I don't know if they are going to fix it in
time, is that somehow Mach-O's file URL handler will spot these
old-style file URLs and handle them correctly.
(Reporter)

Comment 1

15 years ago
Assigning to varga
Assignee: chanial → varga

Comment 2

15 years ago
This is a dup of our other CFM/MachO path bugs.
Whiteboard: dupme
(Reporter)

Updated

15 years ago
Blocks: 195984
(Reporter)

Comment 3

15 years ago
That's fine. I just wanted to make sure I have a bug for our macho bookmark testing.
This was fixed by checkin for bug 197379.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.