DNS: empty page if I change my webserver ip while running moz and already visited page

VERIFIED DUPLICATE of bug 174590

Status

()

defect
VERIFIED DUPLICATE of bug 174590
16 years ago
16 years ago

People

(Reporter: d-n-s, Assigned: darin.moz)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030604
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030604

I have a Webserver on my HomePC set up with dyndns which offers a url that
points to your current pc/ip and a client to automatic update the ip..
ok so far now I have notice when i restart my internet con _and already have
visited the url with mozilla_ and mozilla is still running then trying to _visit
the url again_ it gives me a empty page seems like mozilla is caching the server
ip in some way - solution restart mozilla nothing else works for me ( clearing
cache etc. )


------------------
Mozilla 1.3
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030604
Linux localhost 2.4.20-ck6 #6 Sam Jun 7 15:34:45 CEST 2003 i686 AMD Athlon(tm)
Processor AuthenticAMD GNU/Linux


Reproducible: Always

Steps to Reproduce:
1. Visit your Webserver per URL ( eg. www.something.de )
2. Change the Servers IP
3. Visit same URL again.

Actual Results:  
Mozilla display a empty page with white background..

Expected Results:  
Displaying the contents of the webserver

Comment 1

16 years ago
Dupe of bug 174590, see also bug bug 151929 comment 7, and bug 151929. Yes,
Mozilla caches the IP-address, but there's also a reason for it.

Workaround: use the 'offline' icon in the lower right to go offline and online
again. This will clear the cache in Mozilla, but the IP might still be cached in
the OS, or inside your DNS-server.

*** This bug has been marked as a duplicate of 174590 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Depending on the version of linux you have, the connection request should
eventually time out, but that can be a long time.

Pleaase try the workaround and mark VERIFIED/dupe if Jo described it correctly
(I think he did...)
Component: Networking: HTTP → Networking
QA Contact: httpqa → benc
Summary: empty page if I change my webserver ip while running moz and already visited page → DNS: empty page if I change my webserver ip while running moz and already visited page
Reporter

Comment 3

16 years ago
ok closing 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.