Context menu remain visible after clicking in main menu

RESOLVED DUPLICATE of bug 204770

Status

()

Core
XUL
--
minor
RESOLVED DUPLICATE of bug 204770
15 years ago
10 years ago

People

(Reporter: Alfonso Martinez, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

After the context menu on any page is opened, if you click on the main menu bar
(on an item), let's say "Tools", the Tools menu flashes a moment and the context
menu of the page remains there, now if you click on the page it won't go away
until you right click and click again. If you change tabs the menu remains there.

Same thing happens if instead of pressing an item in the main menu bar you press
the url combo drop down button.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
I can also see this with trunk build 2003050908 on Win2k.

Comment 2

15 years ago
The same thing happens when you right-click on a tab or the tab bar.
When the context menu of a tab or the tab bar is opened, you must first
right-click and then left-click on the tab bar, it won't help clicking on the
page itself.

Comment 3

15 years ago
Works correctly with the 1.3 release on Win2k.

Comment 4

15 years ago
Seems to be related to Bug 204770, have a look at
http://bugzilla.mozilla.org/show_bug.cgi?id=204770#c12
(Reporter)

Comment 5

15 years ago
Yes, it seems to be the same problem. 

I'll mark this one as a dup and if fixing bug 204770 doesn't fix this one, I'll
reopen it.

*** This bug has been marked as a duplicate of 204770 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.