Security Module fails for HTTPS site without prompting for FIPS password.

VERIFIED DUPLICATE of bug 200775

Status

Core Graveyard
Security: UI
--
major
VERIFIED DUPLICATE of bug 200775
15 years ago
a year ago

People

(Reporter: Infernoz, Assigned: Stephane Saux)

Tracking

1.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: mozilla-win32-1.4b-installer-sea.exe (12,155,600 bytes), dated 07 May 2003 22:59:16

I have a FIPS password set from Mozilla 1.3, with "The first time its needed"
prompting.  I'm running Windows XP Pro (not SP1) with 1.5G of RAM, no swap file
with an Ethernet/ADSL512 Internet connection.

When I ran Mozilla 1.4b and entered an HTTPS address (any works), a dialog
appeared saying that the security module had failed, no FIPS prompt or anything
else.  IMHO this is a serious fault because I use SLL for purchasing and email,
so I had to downgrade back to Mozilla 1.3 and live with the following fault:

Mozilla 1.3 also had FIPS issues e.g. https://www.chillblast.com reliably
crashes Mozilla (if the 1st SSL site visited) because the central frame links to
a CSS file on the HTTPS server and the FIPS passwork prompt causes a deadlock
and crash.  Mozilla 1.4a did not fix this issue, so I downgraded from that too.


Reproducible: Always

Steps to Reproduce:
1. Goto any SSL site.
2.
3.

Actual Results:  
For the SSL site, a dialog appeared saying the security module had failed, it
didn't even ask me for my FIPS passwork.

The security preferences don't allow me to use any useful security functionality
because I hadn't been prompted for my FIPS password.  I don't consider reseting
the password as useful because I would loose all my data, probably for nothing.

Expected Results:  
Prompt me for my FIPS password for the 1st SSL site.

Allow me to use the security preferences.

Comment 1

15 years ago
did you uninstall Moz 1.3 before installing 1.4b ?
SSL-related issues are PSM, not browser.
Assignee: mstoltz → ssaux
Component: Security: General → Client Library
Product: Browser → PSM
QA Contact: carosendahl → bmartin
Version: Trunk → 2.4
(Reporter)

Comment 3

15 years ago
No I didn't, at first (IMHO I shouldn't have, any uninstall should be automatic,
if required).

Next try I uninstalled Mozilla and tried again, it still failed.

I had enough and reinstalled Mozilla 1.3 and it got confused a few times before
it rediscovered my profile, so I could see my bookmarks again, scary as I
thought I had lost all my bookmarks initially.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 200775 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
V
Status: RESOLVED → VERIFIED

Updated

13 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.4 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.