TBODY with overflow property puts scrollbars over the tbody contents

RESOLVED DUPLICATE of bug 28800

Status

()

Core
Layout: Tables
--
minor
RESOLVED DUPLICATE of bug 28800
15 years ago
15 years ago

People

(Reporter: Hakon, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131
Build Identifier: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

When giving the TBODY a css property like { overflow: auto } or { overflow:
scroll } - the scrollbars appear overlayed to the tbody contents, so that the
last part of the rightmost cell gets obscured by the scrollbars. Also, the same
problem with horizontal scrollbars and the last table-row.
Another thing is that it looks bad or even buggy, since the nice table-cell grid
layout gets broken to the right.

Reproducible: Always

Steps to Reproduce:
1. Check the attached testcase
Actual Results:  
Some contents get obscured by the scrollbars.

Expected Results:  
I think that it would be better if there was a behaviour as suggested by the
inline image.
(Reporter)

Comment 1

15 years ago
Created attachment 122996 [details]
this is for inclusion in the html page
(Reporter)

Comment 2

15 years ago
Created attachment 122997 [details]
This shows the problem

Comment 3

15 years ago
This is probably a duplicate of bug 28800.

Comment 4

15 years ago
indeed its a dupe

*** This bug has been marked as a duplicate of 28800 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.