Status

()

--
critical
VERIFIED DUPLICATE of bug 204781
16 years ago
16 years ago

People

(Reporter: dbixler, Assigned: rogerl)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Going to the provided URL crashes the web browser (and email client, etc.).  I
believe it's related to Javascript though I cannot verify it.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL provided
2. Wait about 15 seconds
3. If it doesn't crash, go to the menu option Calculations->Milliwatts vs. dBm

Actual Results:  
Browser crashes

Expected Results:  
Not crash

Comment 1

16 years ago
Can see same behaviour, Win2k, 1.4beta.  

Would the bug title be betters as something like :

"Hang when viewing http://www.ydi.com (memory could not be written error)"?
It's the CSS popup.

nsEventStateManager::GenerateMouseEnterExit(nsEventStateManager * const
0x06085030, nsIPresContext * 0x078694a0, nsGUIEvent * 0x0012fa40) line 2686 + 5
bytes
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x06085024,
nsIPresContext * 0x078694a0, nsEvent * 0x0012fa40, nsIFrame * 0x07de86dc,
nsEventStatus * 0x0012f96c, nsIView * 0x07b75390) line 404
PresShell::HandleEventInternal(PresShell * const 0x06085030, nsEvent *
0x00000000, nsIView * 0x07b75390, unsigned int 1, nsEventStatus * 0x0012f96c)
line 6387
PresShell::HandleEvent(PresShell * const 0x00000000, nsIView * 0x07b75390,
nsGUIEvent * 0x0012fa40, nsEventStatus * 0x0012f96c, int 0, int & 22922320) line
6291 + 19 bytes
nsViewManager::HandleEvent(nsViewManager * const 0x06085030, nsView *
0x00000004, nsGUIEvent * 0x0012fa40, int 0) line 2292
nsView::HandleEvent(nsView * const 0x06085030, nsViewManager * 0x0774c610,
nsGUIEvent * 0x0012fa40, int 0) line 308
nsViewManager::DispatchEvent(nsViewManager * const 0x0774c610, nsGUIEvent *
0x07bb9b60, nsEventStatus * 0x0012f9ec) line 2022 + 30 bytes
HandleEvent(nsGUIEvent * 0x0012fa40) line 82
nsWindow::DispatchEvent(nsWindow * const 0x03e4ab24, nsGUIEvent * 0x0012fa40,
nsEventStatus & nsEventStatus_eIgnore) line 1054 + 3 bytes
nsWindow::DispatchWindowEvent(nsWindow * const 0x06085030, nsGUIEvent *
0x00000000) line 1075
nsWindow::DispatchMouseEvent(nsWindow * const 0x06085030, unsigned int 300,
unsigned int 0, nsPoint * 0x00000000) line 5198
ChildWindow::DispatchMouseEvent(ChildWindow * const 0x06085030, unsigned int
300, unsigned int 0, nsPoint * 0x00000000) line 5452 + 19 bytes
nsWindow::ProcessMessage(nsWindow * const 0x06085030, unsigned int 512, unsigned
int 0, long 13172965, long * 0x0012fd10) line 3976
nsWindow::WindowProc(HWND__ * 0x002103e4, unsigned int 0, unsigned int 0, long
65317668) line 1348 + 16 bytes
USER32! 77e2a244()
USER32! 77e045e5()
USER32! 77e0a792()
nsAppShellService::Run(nsAppShellService * const 0x00ef3f80) line 479
main1(int 0, char * * 0x00243de8, nsISupports * 0x00000000) line 1268 + 9 bytes
main(int 3, char * * 0x00243de8) line 1647 + 22 bytes
WinMain(HINSTANCE__ * 0x00400000, HINSTANCE__ * 0x00400000, char * 0x001334ee,
HINSTANCE__ * 0x00400000) line 1671 + 23 bytes
MOZILLA! WinMainCRTStartup + 308 bytes
KERNEL32! 77e9847c()

*** This bug has been marked as a duplicate of 204781 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Verified Duplicate.

Dave: thank you for this report. You have been cc'ed on bug 204781
so that you can follow progress on this issue -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.