[Performance] Add Bookmarks Dialog's 'Create In' Drop down menu is very slow when there is many folders in bookmark.

VERIFIED DUPLICATE of bug 178514

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 178514
15 years ago
12 years ago

People

(Reporter: noririty, Assigned: Pierre Chanial)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
It's too slow to appear 'Create In' drop down dialog box's contents when I
Choose [Bookmark]-[Add Bookmark...]

I compared the [Tool]-[Options]-[General]-[Use Bookmark] dialog with this. The
result is 'Use Bookmark' dialog appears faster than 'Add Bookmarks' Dialog.
Obviously there is plenty of room for improvement.

Does anyone know this reason?

Comment 1

15 years ago
I think it's from difference between <tree> and other widgets.
The <tree> widget is a special widget, it's implemented partially native, it
processes only on-displayed items and it's RDF-template-oriented for performance
of heavy components such as bookmarks, history and so on.

Thus I propose using <tree> widget for 'Add Bookmarks' dialog as Mozilla
SeaMonkey does now.
(Assignee)

Comment 2

15 years ago
the menu is populated in js, we should indeed use a tree
(Reporter)

Comment 3

15 years ago
*** Bug 207856 has been marked as a duplicate of this bug. ***
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 5

15 years ago
Bug 178514 asks for a tree view there as well. Please reopen if you don't want a
tree view but make the current list faster.

*** This bug has been marked as a duplicate of 178514 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
VERIFIED
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.