Special characters are lost after a palm sync ( €, ™)

RESOLVED DUPLICATE of bug 237624

Status

MailNews Core Graveyard
Palm Sync
RESOLVED DUPLICATE of bug 237624
15 years ago
9 years ago

People

(Reporter: Ninoschka Baca, Unassigned)

Tracking

Trunk
x86
Windows ME

Details

(Reporter)

Description

15 years ago
Trunk build 2003-05-13: WinMe

Overview: After a palm sync certain special characters are lost. They either
become a "." or a "?". 

Steps to reproduce from Mozilla AB --> Palm Device:
1. In the Mozilla AB create cards for using the following special characters
a. Euro --> alt+0+128 = €
b. Tradmark --> alt+0+153 = ™
2. Perform a palm sync

Actual Results: The Mozilla AB retains the correct symbols but the palm device
has turned the Euro and the Trademark into a ".".

Steps to reproduce from Palm Device --> Mozilla AB:
1. On the palm device create a record using the Euro symbol
a. Euro --> alt+0+128 = €
2. Perform a palm sync

Actual Results: The Palm Device retains the euro symbol but the Mozilla AB
displays a "?".

Expected Results: In both scenarios the special character symbol should be retained.
(Reporter)

Comment 1

15 years ago
Marking nsbeta1 because I would think that a trademark symbol would be important
and that the international group would need this fix as well.

Interesting: An ISO 8859-1 (Latin-1) Character List shows "--" for the key
sequence used for the Euro and Trademark symbol. (Here is a link to the
characters list http://www.utoronto.ca/webdocs/HTMLdocs/NewHTML/iso_table.html)
Keywords: nsbeta1

Comment 2

15 years ago
Bob, Cavin
since euro and trademark are not a part of the 8859-1 code page how do we do
conversion when sync'ing?
Summary: Special characters are lost after a plam sync ( €, ™) → Special characters are lost after a palm sync ( €, ™)

Comment 3

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 4

14 years ago
Confirming. (On Windows 2000) Creating a record in Mozilla AB with € and ™
results in  ¬ and " showing on the Palm entry respectively.

Creating a record on the Palm with € and ™ results in the entry's title
containing blocks and the entry itself missing them in Mozilla AB.
Product: MailNews → Core

Updated

13 years ago
Assignee: cavin → nobody
QA Contact: nbaca

Comment 5

13 years ago
cc to bug 237624 for (hopefully) eventual fix

*** This bug has been marked as a duplicate of 237624 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

9 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.