home and end keys illogical when using carret broswing

VERIFIED DUPLICATE of bug 143996

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 143996
15 years ago
15 years ago

People

(Reporter: James Nord, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030505)

The home and end keys map to start and end of document in the broswer, however
they should map to start/end of line when carret-browsing is enabled

Steps to repro,
1) start moz
2) enable caret broswing (F7)
3) place the cursor in the middle of a line
4) press home

expected results,
the caret moves to the start of the line

actual results
the caret moves to the start of the document

(note shift+home/end do the right thing TM and select to the start of the line)
(Assignee)

Comment 1

15 years ago
*** Bug 205643 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

15 years ago
*** This bug has been marked as a duplicate of 143996 ***

*** This bug has been marked as a duplicate of 143996 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.