Closed Bug 205679 Opened 17 years ago Closed 15 years ago

cursor behaves wrong at unicode characters in input field

Categories

(Core :: Selection, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 301033

People

(Reporter: ftomi, Assigned: mjudge)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

cursor behaves wrong at (some) unicode characters in <input> field: when the
cursor at the left of a special character, pressing right: doesn't affect the
cursor position, pressing once again: the cursor budged two places.

Reproducible: Always

Steps to Reproduce:
Write an utf-8 encoded html. Create an input field with special unicode
characters (such as hebrew) at its value. Enter the inputbox, ant try the cursor.

short demonstration at the mentioned url
Actual Results:  
cursor steps behaves incorrect

Expected Results:  
the cursor should speps charater by charater
-> selection
Assignee: aaronl → mjudge
Component: Keyboard: Navigation → Selection
QA Contact: sairuh → pmac
This behavior isn't related to Unicode, it occurs with any similar BiDi pattern
(even with ISO-8859-8 pages). Now, since bug 207186 already deals specifically
with such issues, I will mark this one as a dupe and add the steps needed to
reproduce it with one of the existing testcases there.

Thanks for reporting this,

Prog.

*** This bug has been marked as a duplicate of 207186 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Reopening in order to dupe to bug 301033 - which is a more complete description
of this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 301033 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.