Divs nested within fieldsets won't accept a margin-top definition

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: fraser.crichton, Unassigned)

Tracking

({css1, testcase})

Trunk
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

I'm trying to set a top margin on a div nested within a fieldset in CSS. Mozilla
let's me specify left and right margins but not top margins. Is there something
weird about the box model here? 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Margin top on Fieldset</title>
</head>
<body>

<form style="padding: 0;" action="hh.htm" method="get">
	<fieldset style="display: block; background-color: blue;">
	<legend>hkjh</legend>
	<div style="margin-top: 400px; background-color: #ccffcc;">
	Blah  <input type="text" id="test" name="test" value="test text" /> <br />
	</div>
	</fieldset>
</form>
</body>
</html>



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Doesn't accept the top margin defintion (IE does).

Expected Results:  
There should be a bit of space there.

Comment 1

14 years ago
This has probably to do with special handling for FIELDSET.
Assignee: core.layout.form-controls → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: css1, testcase
QA Contact: desale → core.layout.form-controls

Comment 2

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060912 Minefield/3.0a1

This works for me on current trunk and branch. ->WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → WORKSFORME

Comment 3

12 years ago
*** Bug 299956 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.