In Debug's XBL Test Suite, Rollover Madness causes Mozilla to crash

RESOLVED DUPLICATE of bug 204781

Status

()

Core
XBL
RESOLVED DUPLICATE of bug 204781
15 years ago
15 years ago

People

(Reporter: Waldo, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

First off, sorry if the Debug menu is supposed to have problem areas in it; I
couldn't find documentation telling me what its exact purpose was, so I'm
posting this to let developers know if they didn't.

Just fooling around after downloading Mozilla 1.4b and going through the Debug
menu I hadn't seen in the previous Mozilla version I had (probably there, I just
missed it).  Anyways, I'm looking at ones with interesting names and see
Debug->XBL Test Suite->#2 Rollover Madness.  Sounds interesting, so I open it. 
So far, no problem.  I read the instructions and roll the cursor over the div. 
Cool, it gets bigger!  Then, when I move the cursor off the div, Mozilla crashes
on me.

This bug applies at least to the WinXP version of Mozilla 1.4b, because this
happens every time I try it on two different WinXP computers.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.mozilla.org/projects/xbl/test2/test.html
2. Roll the mouse over the div and watch the pretty effect.
3. Move the cursor off the div and watch something hit the fan...

Actual Results:  
The mouse cursor goes to busy, Talkback starts up, XP comes in with its program
error message box saying that XP has to close Mozilla due to an error and asks
if I will send them an error report.

Expected Results:  
I'm not sure, but the browser certainly should not have crashed.

I am using Mozilla {Build ID: 2003050714} as shown in the browser title bar.

Comment 1

15 years ago
dup adn fixed again in current trunk.

*** This bug has been marked as a duplicate of 204781 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.