paste large clipboard into textarea does not show up correctly

RESOLVED DUPLICATE of bug 56219

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 56219
15 years ago
13 years ago

People

(Reporter: Kris Yates, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

I have developed some web based content management systems which use textareas
to allow user to input code/chunks of site which are saved to a database. 
Occasionally, when I cut and paste a large clipboard into a textarea, it does
not paste correctly.  Sometimes it loses part of the paste but more often after
pasting, you just dont see anything.  It only seems to occur when the data to be
put in the textarea is 'large', say 15k or more?  

Reproducible: Sometimes

Steps to Reproduce:
1.create a form with textarea
2.paste a 15 - 30k document into it
3.
Actual Results:  
Sometimes it works and I see my entire clipboard contents pasted into the
textarea properly.  Sometimes it gets most of the contents into the textarea. 
Sometimes I see nothing after I paste.

Expected Results:  
Accepted full clipboard contents to be pasted into textarea

I am also able to recreate this on Mozilla/OSX.  Sometimes restarting the
browser helps.  Sometimes I have to just go find another machine and use IE or
Opera, however, it seems Opera has the same problem but less often.  I have
never been able to recreate the problem using IE for PC.  Hope this helps!  Let
me know what you find or can tell me about this.

Comment 1

15 years ago
please try 1.4b.  1.0.1 is a year old.

Comment 2

15 years ago
Same triubles with 1.4b under Linux

Comment 3

15 years ago
Only one way to copy large ammount of text data to mozilla - is to save that 
text to html and then open as file in mozilla, copy it to clipboard and paste 
to textarea :(

Comment 4

15 years ago
I am able to reproduce this (OpenOffice.org 1.1beta2 and Mozilla 2003-05-12-05
on Linux). The caret in the textarea stalls for a second, then it starts
blinking again but no text appears. Could we please mark this bug as new or dupe
it to something else?

Is this this same problem we get copying the text of an OpenOffice.org (OOo)
word processor document into Mozilla e-mail message? This doesn't work with OOo
1.1beta2 and Mozilla 2003-05-12-05. There is an OOo bug for this:

<http://www.openoffice.org/issues/show_bug.cgi?id=13235>

That OOo bug was closed as invalid because the analysis was that this is a
Mozilla bug:

   AFAIK this was a bug in Mozilla. Mozilla pretent to support 
   the clipboard format text/html but it wasn't able to

Please indicate whether this pasting into an e-mail message is the same bug or
not. If not, i'll file a new bug. 

Comment 5

15 years ago
looks like bug 56219

*** This bug has been marked as a duplicate of 56219 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.